Bug 863991 - perl-Coro-6.09 does not build on S390
perl-Coro-6.09 does not build on S390
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Coro (Show other bugs)
rawhide
s390 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 05:24 EDT by Petr Pisar
Modified: 2012-12-10 16:37 EST (History)
5 users (show)

See Also:
Fixed In Version: perl-Coro-6.09-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 16:37:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 80056 None None None 2012-10-08 05:26:58 EDT

  None (edit)
Description Petr Pisar 2012-10-08 05:24:56 EDT
Coro 6.09 fails to build on big endian machine because of typo in bundled Coro/ecb.h file:

$ gcc -c   -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m31 -march=z9-109 -mtune=z10   -DVERSION=\"6.09\" -DXS_VERSION=\"6.09\" -fPIC "-I/usr/lib/perl5/CORE"  -DHAVE_MMAP -DCORO_UCONTEXT -DCORO_STACKSIZE=16384 -DCORO_STACKGUARD=4 -DCORO_JIT=1 State.c
In file included from State.xs:17:0:
ecb.h: In function 'ecb_byteorder_helper':
ecb.h:497:3: error: 'retrurn' undeclared (first use in this function)
Comment 1 Fedora Update System 2012-10-08 07:51:25 EDT
perl-Coro-6.09-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-Coro-6.09-2.fc18
Comment 2 Fedora Update System 2012-10-08 11:28:44 EDT
Package perl-Coro-6.09-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Coro-6.09-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15627/perl-Coro-6.09-2.fc18
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.