Bug 864026 - RFE remote-viewer connection dialog should handle connection errors
Summary: RFE remote-viewer connection dialog should handle connection errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 921438 977247
TreeView+ depends on / blocked
 
Reported: 2012-10-08 11:48 UTC by Tomas Jamrisko
Modified: 2013-11-21 08:02 UTC (History)
9 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Enhancement
Doc Text:
Feature: Connection dialog should handle connection errors Reason: remote-viewer started without any parameters on command line first opens a small interface which allows user to specify connection parameters. However, it terminates the client when the connection parameters aren't valid. Result (if any): Now the connection dialog handles errors, and allows to correct the connection details and to try a new connection.
Clone Of:
: 921438 977247 (view as bug list)
Environment:
Last Closed: 2013-11-21 08:02:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description Tomas Jamrisko 2012-10-08 11:48:19 UTC
Description of problem:
remote-viewer started without any parameters on command line first opens a small interface which allows user to specify connection parameters. The problem is, that it terminates when the connection parameters aren't valid for any reason

Version-Release number of selected component (if applicable):
(all; happens on rhel 7, rhel 6, windows) 

How reproducible:
Always 


Steps to Reproduce:
1. Start remote-viewer and do not pass any parameters
2. Enter some bogus url
3. try to connect
  
Actual results:
remote-viewer terminates after unsuccessful attempt to connect

Expected results:
It shouldn't quit in this use-case, but rather fall back to gui and give user the "power" to change parameters

Comment 4 Marc-Andre Lureau 2013-05-08 15:25:37 UTC
Afaik, there is no good incentive to fix this, since remote-viewer is a simple client front-end mainly for RHEV integration. An application like Boxes is better suited to provide nice UI etc. And it's not necessarily so trivial as it involves UI etc.. moving to RFE,

Comment 5 Marc-Andre Lureau 2013-05-17 12:27:40 UTC
I have a few patches to improve this, moving to POST.

Comment 10 tingting zheng 2013-07-04 09:48:41 UTC
I can reproduce this issue with:
virt-viewer-0.5.2-18.el6_4.2.x86_64

Tested it with:
virt-viewer-0.5.6-1.el6.x86_64

After input some bogus url,remote-viewer doesn't quit,it fall back to gui and give user the "power" to change parameters.So move the bug to VERIFIED.

Comment 13 errata-xmlrpc 2013-11-21 08:02:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.