Bug 864029 - Gnome-contacts ignores gnome-online-accounts settings
Gnome-contacts ignores gnome-online-accounts settings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-contacts (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: beta
: 7.0
Assigned To: Alexander Larsson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 07:55 EDT by Martin Simon
Modified: 2016-09-19 22:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:22:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simon 2012-10-08 07:55:34 EDT
Description of problem:
In gnome-online-accounts can be set whether it want to use google account for contacts (or mail, calendar, etc..), but ii I toggle contacts to off, it has no effect on google-contacts, it's simply ignored.


Version-Release number of selected component (if applicable):
gnome-contacts-3.6.0-2
gnome-online-accounts-3.6.0-1

How reproducible:
100%

Steps to Reproduce:
1. Have an google account in online-accounts added
2. turn off contacts in the google accounts
3. start gnome-contacts
  
Actual results:
All google contacts are there

Expected results:
There shouldn't be any google contact as I disabled them

Additional info:
Comment 3 Vitezslav Humpa 2013-11-07 05:57:58 EST
Still an issue with gnome-online-accounts 3.8.5 and gnome-contacts 3.8.2.

Basically, if an account is configured via GOA, gnome-contacts always shows contacts, disregarding the ON/OFF switch in GOA panel. This should be fixed in time for EL7.
Comment 4 RHEL Product and Program Management 2014-03-22 03:05:06 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Bill Sanford 2015-05-13 15:01:41 EDT
This is fixed in gnome-shell-3.14.2-3.
Comment 8 Vera Budikova 2015-08-29 20:50:46 EDT
Verification:

Package version: gnome-contacts-3.14.2-2.el7.x86_64

Steps:
1. Have an google account in online-accounts added
2. Turn off contacts in the google accounts
3. Start gnome-contacts
4. Check if google accounts disappear

Result:
There are not any google contact as I disabled them

According to comment https://bugzilla.redhat.com/show_bug.cgi?id=864029#c6 and my testing -> verified.
Comment 9 errata-xmlrpc 2015-11-19 02:22:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2215.html

Note You need to log in before you can comment on or make changes to this bug.