Bug 864033 - Installer shouldn't proceed while there are other instances runnin
Installer shouldn't proceed while there are other instances runnin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On: 872541
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 08:04 EDT by Tomas Jamrisko
Modified: 2013-04-10 11:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.3-12.el6
Doc Type: Bug Fix
Doc Text:
Previous versions of mingw-virt-viewer installer would not recognize if another instance of remote/virt-viewer was running, resulting in a failure to update certain files. The installer now displays a warning that another instance of either virt-viewer or remote-viewer is running and prevents the installation from continuing.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 12:59:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2012-10-08 08:04:14 EDT
Description of problem:
Installer doesn't check whether or not is another instance of remote/virt-viewer running -- more specifally proceeds even if some files that need to be replaced during installation (binary), or removal (spicex.dll), are already open by other application -> they aren't updated.

Version-Release number of selected component (if applicable):
mingw-virt-viewer-0.5.3-11.el6

How reproducible:
Always

Steps to Reproduce:
1. Install virt-viewer manually using installer
2. Connect to a running vm
3. Now login to rhevm -- this will prompt another installation, because spicex isn't installed just yet
4. Connect to a VM in rhevm
  
Actual results:
The installer will proceed as if nothing was happening, and will fail to update some files
You should notice some character encoding problems in remote-viewer user interface 

Expected results:
The installer should warn about running instances of remote-viewer.

Additional info:

Also uninstalation fails to remove spicex.dll if user is connected to RHEVM using IE -- but this is reported as https://bugzilla.redhat.com/show_bug.cgi?id=864003 which should effectively fix the issue...
Comment 1 Marc-Andre Lureau 2012-10-19 16:36:12 EDT
This is actually quite complicated to handle, unfortunately. Let's add a warning and error out if there is already a running instance of either virt-viewer, remote-viewer or the installer itself. However potentially, any of the other files may be in use, by any other application, at any tiem, and it's seems really hard to prevent that, so there is some chance it still fails. Using the same kernel mutex should solve at least the common case.
Comment 2 Marc-Andre Lureau 2012-10-19 18:57:58 EDT
sent a patch series to virt-tools ML for a possible solution
Comment 5 David Jaša 2012-11-02 09:12:10 EDT
This bug actually depends on bug 872541, the use case being:

There are two users connected at the same time, first has IE with activex loaded or r-v running and second wants to "install for all users": the installation shouldn't proceed in this scenario either (IMHO no matter if the running instance is "per-user" or "all users" one).
Comment 6 Marc-Andre Lureau 2012-11-02 09:20:44 EDT
(In reply to comment #5)
> This bug actually depends on bug 872541, the use case being:

> There are two users connected at the same time, first has IE with activex
> loaded or r-v running and second wants to "install for all users": the
> installation shouldn't proceed in this scenario either (IMHO no matter if
> the running instance is "per-user" or "all users" one).

I don't think we should mix activex / cab single-user use case with msi / admin use case. You are asking too much at the same time. We have like 3 different ways (at least) to install virt-viewer, we should solve problems one by one. Please consider removing the blocker.
Comment 7 Marian Krcmarik 2012-11-06 14:27:49 EST
(In reply to comment #6)
> (In reply to comment #5)
> > This bug actually depends on bug 872541, the use case being:
> 
> > There are two users connected at the same time, first has IE with activex
> > loaded or r-v running and second wants to "install for all users": the
> > installation shouldn't proceed in this scenario either (IMHO no matter if
> > the running instance is "per-user" or "all users" one).
> 
> I don't think we should mix activex / cab single-user use case with msi /
> admin use case. You are asking too much at the same time. We have like 3
> different ways (at least) to install virt-viewer, we should solve problems
> one by one. Please consider removing the blocker.

Ok, We will verify this bug for one user case. The use case of two users when one of them has activex loaded and virt-viewer running works for me - the other user can install activex/virt-viewer and run it without problems.
Comment 10 errata-xmlrpc 2012-12-04 12:59:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1525.html

Note You need to log in before you can comment on or make changes to this bug.