Bug 864038 - Window doesn't maximize
Window doesn't maximize
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 08:18 EDT by Tomas Jamrisko
Modified: 2013-05-10 07:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 07:58:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screencast (1.25 MB, video/ogg)
2012-10-30 11:46 EDT, Tomas Jamrisko
no flags Details

  None (edit)
Description Tomas Jamrisko 2012-10-08 08:18:49 EDT
Description of problem:
Windows 7 -- both guest and client, vdservice running on guest

Having a relatively small (less than half of screen size in both dimensions) remote-viewer windows on client, and attempting to maximize it using the button in upper right corner results in the window not being scaled up properly -- it attempts to maximize, but ends just halfway there

Version-Release number of selected component (if applicable):
mingw-virt-viewer-0.5.3-11.el6
qemu-kvm-rhev-0.12.1.2-2.295.el6*, spice-server-0.10.1-*
Tools from RHEVM3.0

How reproducible:
Always

Steps to Reproduce:
1. Connect to a Windows 7 guest from a windows 7 client
2. Resize the window to something relatively small
3. Try to maximize
  
Actual results:
Window isn't maximized

Expected results:
It should be

Additional info:

****This bug seems to be *FIXED* in the latest packages which are in RHEVM3.1 to be (qxl-win-unsigned-0.1-15, vdagent-win-0.1-12, virtio-serial from virtio-win-prewhql-0.1-39)****
Comment 1 Marc-Andre Lureau 2012-10-29 14:11:03 EDT
I can't reproduce, can you try with latest mingw-virt-viewer-0.5.3-12 ? Do you have the guest configured with agent & qxl driver? You could also try to record your desktop so we could see what's happening.
Comment 2 Tomas Jamrisko 2012-10-30 11:42:00 EDT
Well, as I mentioned -- this problem can't be reproduced when newer versions of vdagent and qxl are installed on the guest -- so if you believe that the problem doesn't need any further fixes in virt-viewer feel free to close it. 

*However* the problem still happens with new version of virt-viewer (vdagent and qxl have to be older though).
Comment 3 Tomas Jamrisko 2012-10-30 11:46:10 EDT
Created attachment 635678 [details]
screencast

This is what happens when one tries to maximize remote-viewer (2 attempts in total) -- cursor isn't captured

As you can see -- the window first maximizes, and change of resolution to best fit the window causes the window to decrease its size (yet the button still shows it's maximized)
Comment 4 Marc-Andre Lureau 2012-10-30 13:42:15 EDT
thanks for the screencast

(In reply to comment #3)
> As you can see -- the window first maximizes, and change of resolution to
> best fit the window causes the window to decrease its size (yet the button
> still shows it's maximized)

This is a difference of behaviour between gtk on windows and linux. We call gtk_window_resize() even when the window is maximized, and this cause the window to leave the maximize state on Windows. I believe the fix should be in gtk+. Working around that problem in virt-viewer isn't really a practical solution, and will make the code more complicated.

Anyway, given that newer driver/agent solves the issue (since we get exact resolution, we don't need to resize later on), I would lower the issue for now.
Comment 6 RHEL Product and Program Management 2012-12-14 01:51:33 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 Marc-Andre Lureau 2013-05-09 15:53:26 EDT
Afaik, this was windows only bug which got fixed in rhev 3.2. right Tomas?
Comment 9 Tomas Jamrisko 2013-05-10 03:33:51 EDT
You are right, it was windows only. And yes, it seems to be fixed. But I have honestly no idea about when, Must have been in 3.2, but since this is reported against spice-gtk, which is only in RHEL...
Comment 10 Marc-Andre Lureau 2013-05-10 07:58:40 EDT
thanks Tomas, let's close as current release then,

Note You need to log in before you can comment on or make changes to this bug.