This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 864039 - [RFE] show ack/nack status of all recipes, not just your own
[RFE] show ack/nack status of all recipes, not just your own
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.9
Unspecified Unspecified
low Severity medium (vote)
: ---
: ---
Assigned To: Raymond Mancy
GroupModel
: FutureFeature
Depends On: 961580
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 08:20 EDT by Ales Zelinka
Modified: 2014-12-07 20:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-16 11:13:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2012-10-08 08:20:10 EDT
Description of problem:Currently I can't see if someone else's recipe is acked or nacked. 


Version-Release number of selected component (if applicable):
0.9.3 

Steps to Reproduce:
1. login as azelinka
2. open https://beaker.engineering.redhat.com/jobs/311092 
  
Actual results:
can't see which recipesets are acked and whcih are nacked

Expected results:
can see acks/nacks
Comment 1 Dan Callaghan 2013-02-06 22:16:36 EST
This will be addressed by allowing users to submit jobs for groups, and allowing all group members to ack/nack group jobs.
Comment 2 Nick Coghlan 2013-05-10 00:06:08 EDT
It's possible this is superseded by bug 961580 - it should be revisited once that feature has been implemented.
Comment 3 Dan Callaghan 2014-05-21 20:10:20 EDT
Ales, have the group jobs and submission delegate features satisfied your needs here? Or do you still want to be able to see the ack/nack state of other people's jobs?

I think there's no reason to hide it (since in general, all details of all jobs are visible to all users). The only reason it's not visible already is probably because nobody bothered to implement a read-only view of ack/nack state in the UI.
Comment 4 Ales Zelinka 2014-06-16 11:13:10 EDT
Hmm, I no longer remember my usecase :) But I guess it had something to do with our automation that schedules user jobs under its own identity preventing users from seeing the ack/nack status. Submission delegates should fix that => closed-not
Comment 5 Ales Zelinka 2014-06-16 11:13:25 EDT
-a-bug

Note You need to log in before you can comment on or make changes to this bug.