Bug 864058 - anaconda main menu not visible in F18 Beta TC2 KDE Live
anaconda main menu not visible in F18 Beta TC2 KDE Live
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: oxygen-gtk3 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker F18Blocker-kde
  Show dependency treegraph
 
Reported: 2012-10-08 09:23 EDT by Jan Sedlák
Modified: 2012-10-22 18:36 EDT (History)
16 users (show)

See Also:
Fixed In Version: oxygen-gtk3-1.1.1-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 06:51:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
main menu in anaconda (33.78 KB, image/png)
2012-10-08 09:23 EDT, Jan Sedlák
no flags Details
Screenshot of the problem. (53.21 KB, image/png)
2012-10-09 06:54 EDT, Ryan Farmer
no flags Details
disable inner shadows hack (734 bytes, patch)
2012-10-17 01:41 EDT, Cosimo Cecchi
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 686265 None None None 2012-10-17 12:36:01 EDT
KDE Software Compilation 308533 None None None 2012-10-17 12:37:27 EDT

  None (edit)
Description Jan Sedlák 2012-10-08 09:23:34 EDT
Created attachment 623452 [details]
main menu in anaconda

Description of problem:
In F18 TC2 Beta, in KDE live, nothing is visible in the main menu. Main menu is functional, spokes are all right, but main menu is totally blank. See attached screenshot.

How reproducible:
Always.

Steps to Reproduce:
1. Boot into F18 Beta TC2 KDE live
2. start anaconda
  
Actual results:
Nothing shows in the main menu.

Expected results:
Icons and text in main menu should be visible.

Additional info:
Proposing as beta blockerbug per alfa criterion: "The installer must be able to install each of the release blocking desktops, as well as the minimal package set, with each supported installation method"
Comment 1 Ryan Farmer 2012-10-09 06:54:32 EDT
Created attachment 624022 [details]
Screenshot of the problem.

I got a screenshot of this.

It happens in the latest nightly (currently 10/8) too.

Switching to the GTK Raleigh theme make the menu items visible again.
Comment 2 Martin Kho 2012-10-09 09:52:06 EDT
Hi,

Installed anaconda-18.14-1.fc18.x86_64 and got the same invisible result. With the 'default' graphics nouveau driver and the 'basic graphics driver' (vesa?) Starting /usr/bin/liveinst at the command prompt gives the following messages:

"localuser:root being added to access control list
Starting installer, one moment...
anaconda 18.14 for Fedora 18 (pre-release) started.

(anaconda:2770): Gtk-WARNING **: Overriding tab label for notebook

(anaconda:2770): Gtk-WARNING **: Unknown property: GtkGrid.n-rows                                                                                                                                                                            
                                                                                                                                                                                                                                             
(anaconda:2770): Gtk-WARNING **: Unknown property: GtkGrid.n-columns                                                                                                                                                                         
                                                                                                                                                                                                                                             
(anaconda:2770): Gtk-WARNING **: Unknown property: GtkGrid.n-columns                                                                                                                                                                         
                                                                                                                                                                                                                                             
(anaconda:2770): Gtk-WARNING **: Overriding tab label for notebook                                                                                                                                                                           
                                                                                                                                                                                                                                             
(anaconda:2770): Gtk-WARNING **: No object called: mountPointCompletion"

Martin Kho
Comment 3 Chris Lumens 2012-10-09 10:05:07 EDT
Those messages don't have anything to do with this, though that last one is definitely a bug I should fix.

When did you first notice this happening?
Comment 4 Martin Kho 2012-10-09 10:12:03 EDT
Hi Chris,

At least I've added a little :-) For me, it started happening in Beta TC2, never saw it in the alpha fase. I didn't try Beta TC1.

Martin Kho
Comment 5 Martin Kho 2012-10-09 10:35:17 EDT
Hi,

FYI: Just checked why I didn't try Beta TC1 live KDE. Well there were no Beta TC1 Lives :-)

Martin Kho
Comment 6 Martin Kho 2012-10-09 10:36:18 EDT
... the last visible was Alpha TC6.

Martin Kho
Comment 7 Jan Sedlák 2012-10-10 08:36:17 EDT
It was visible in Alpha TC5, I was unable to start anaconda in Alpha TC6 and it was invisible in Beta TC1.
Comment 8 Rex Dieter 2012-10-10 09:35:16 EDT
Seems to be some sort of gtk3/oxygen-gtk3 bug or regression.

gtk3-3.5.10-1.fc18 + oxygen-gtk3-1.1.0-2.fc18 as shipped with f18-Alpha, things work ok.

gtk3-3.6.0-1.fc18 + oxygen-gtk3-1.1.1-1.fc18 (currently included in f18-beta-tc2) exhibits the behavior described here.

I'll do more testing of gtk3 vs oxygen-gtk3 now in an attempt to bisect where things went bad.
Comment 9 Rex Dieter 2012-10-10 09:36:47 EDT
sorry, reassigning back to anaconda mostly so this is easier to find and until I have more evidence where to better triage it.
Comment 10 Rex Dieter 2012-10-10 10:39:08 EDT
OK, bisected the problem down to the upgrade from
gtk3-3.5.12-2.fc18  (the last gtk3 version to have worked wrt to this bug)
to
gtk3-3.5.14-1.fc18 (the first gtk3 version where this bug is present).


It may or may not be relevant that i noticed with < 3.5.14, that I could see anaconda window initially appear as a window prior to it going full screen; and with >= 3.5.14, it starts immediately full screen.

triaging to gtk3 for comment.
Comment 11 satellitgo 2012-10-10 11:04:32 EDT
I also see it in f18 Beta TC3 Live KDE x86_64 DVD
Comment 12 Adam Williamson 2012-10-10 15:02:12 EDT
For the record, this wasn't broken in Alpha (some people seem unclear on that). We didn't epic fail there.

Discussed at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt . Accepted as a blocker per criterion "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods" - the criterion is a bit of a fudge as it's _running_, but really, this one's pretty clear and we don't need to get too tied up in procedure.
Comment 13 satellitgo 2012-10-13 16:32:12 EDT
same in f18 Beta TC3 Live KDE x86_64 with desktop effects off (alt shift f12)
Comment 14 satellitgo 2012-10-14 18:32:39 EDT
same in f18 Beta TC4 Live KDE x86_64
Comment 15 satellitgo 2012-10-14 18:53:19 EDT
menus buttons positions are reversed in KDE anaconda -I know that this is KDE default but is confusing
Comment 16 Kevin Kofler 2012-10-14 19:30:56 EDT
It's an oxygen-gtk feature to adjust the button order in dialogs. Is it changing the order of buttons which aren't OK/Cancel or Yes/No buttons? Then Anaconda is abusing the API (it should use normal pushbuttons, not dialog buttons, for actions which aren't of the usual confirm and cancel type; dialog buttons all have a role, if the button action doesn't actually fit that role, it's used improperly) and it's a bug in Anaconda.
Comment 17 Cosimo Cecchi 2012-10-17 01:38:35 EDT
I spent some time debugging this today, and there are multiple bugs involved; the bulk of the bug is [1] for gtk3, but fixing that reveals some rendering glitches in oxygen-gtk3, for which I filed a patch at [2].

I think in the meantime though, the best choice is to disable the fancy hack oxygen-gtk3 uses to draw the inner shadows until these bugs are fixed - there's a build configuration provided for it.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=686265
[2] https://bugs.kde.org/show_bug.cgi?id=308533
Comment 18 Cosimo Cecchi 2012-10-17 01:41:05 EDT
Created attachment 628523 [details]
disable inner shadows hack
Comment 19 Fedora Update System 2012-10-17 12:22:19 EDT
oxygen-gtk3-1.1.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/oxygen-gtk3-1.1.1-2.fc18
Comment 20 Adam Williamson 2012-10-17 14:57:37 EDT
Discussed at 2012-10-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-17/f18beta-blocker-review-4.2012-10-17-16.00.log.txt . It should be possible to test the fix for this with TC5, or we could build a special KDE live for testing. Either way, we just need to test this, verify the fix, and up-karma the update.
Comment 21 Adam Williamson 2012-10-17 16:11:19 EDT
I built a couple of live images to test this fix, one with 1.1.1-1, one with 1.1.1-2, no other differences. The 1.1.1-1 image shows the bug, the 1.1.1-2 image works, so this is verified as fixed.
Comment 22 Fedora Update System 2012-10-21 23:17:59 EDT
oxygen-gtk3-1.1.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Martin Krizek 2012-10-22 04:44:17 EDT
Confirmed, fixed in TC6.
Comment 24 Kevin Kofler 2012-10-22 17:44:48 EDT
It's "fixed" by a cheap workaround. :-( I'd really like to see the actual issue fixed sooner rather than later…
Comment 25 Matthias Clasen 2012-10-22 18:24:53 EDT
What actual issue do you think is not fixed ?
Comment 26 Cosimo Cecchi 2012-10-22 18:30:47 EDT
(In reply to comment #24)
> It's "fixed" by a cheap workaround. :-( I'd really like to see the actual
> issue fixed sooner rather than later…

If you read comment #17 you can find out I wrote patches for the actual issue(s), and they have been all committed in the relevant upstreams.
Comment 27 Kevin Kofler 2012-10-22 18:36:57 EDT
I know, and thanks for that! But I don't think those fixes are in Fedora yet. The oxygen-gtk3 update which got pushed only disables inner shadows.

Note You need to log in before you can comment on or make changes to this bug.