Bug 864113 - NameError: global name 'size_func_kwargs' is not defined
NameError: global name 'size_func_kwargs' is not defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:532533c77f93708218c18794608...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 11:20 EDT by Reartes Guillermo
Modified: 2012-11-22 22:25 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-18.13-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 22:25:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (803.18 KB, text/plain)
2012-10-08 11:20 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-08 11:20 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-08 11:20 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-08 11:20 EDT, Reartes Guillermo
no flags Details
File: storage.log (559.34 KB, text/plain)
2012-10-08 11:21 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-08 11:21 EDT, Reartes Guillermo
no flags Details
File: environ (761 bytes, text/plain)
2012-10-08 11:21 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (35.93 KB, text/plain)
2012-10-08 11:21 EDT, Reartes Guillermo
no flags Details
File: syslog (77.32 KB, text/plain)
2012-10-08 11:21 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-08 11:21 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.32 KB, text/plain)
2012-10-08 11:21 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-08 11:21 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-08 11:21 EDT, Reartes Guillermo
no flags Details
File: program.log (65.00 KB, text/plain)
2012-10-08 11:21 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-08 11:20:21 EDT
Description of problem:
reclaimed space, wen to custom partitioning,
removed two partitions, one on each disk (i intended to do so)
selected the automatic partition suggestion feature, but the result was an error checking 
partitions so i noticed the that the type was lvm, i switched it back to standar partition then the
unknown error


Version-Release number of selected component:
anaconda-18.12

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.12 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 3252, in device_size
:    return get_pv_space(self.size, len(self.disks), **size_func_kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1850, in setContainerMembers
:    device_space = factory.device_size
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1411, in _destroy_device
:    parents = self.__storage.setContainerMembers(container, factory)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 869, in _save_right_side
:    self._destroy_device(device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1534, in on_selector_clicked
:    self._save_right_side(self._current_selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 188, in _onSelectorClicked
:    cb(selector)
:NameError: global name 'size_func_kwargs' is not defined
Comment 1 Reartes Guillermo 2012-10-08 11:20:44 EDT
Created attachment 623504 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-08 11:20:47 EDT
Created attachment 623505 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-08 11:20:50 EDT
Created attachment 623506 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-08 11:20:53 EDT
Created attachment 623507 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-08 11:21:09 EDT
Created attachment 623508 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-08 11:21:11 EDT
Created attachment 623509 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-08 11:21:13 EDT
Created attachment 623510 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-08 11:21:16 EDT
Created attachment 623511 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-08 11:21:20 EDT
Created attachment 623512 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-08 11:21:22 EDT
Created attachment 623513 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-08 11:21:24 EDT
Created attachment 623514 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-08 11:21:26 EDT
Created attachment 623515 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-08 11:21:29 EDT
Created attachment 623516 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-08 11:21:32 EDT
Created attachment 623517 [details]
File: program.log
Comment 15 Amit Shah 2012-10-11 02:56:50 EDT
For 'root' partition, select type as btrfs from default LVM.  Also select the 'optimise' checkbox.  Generates this crash. This is when running in a KVM VM with a virtio-blk disk as install target.

Package: anaconda-18.12-1.fc18.x86_64
OS Release: Fedora release 18
Comment 16 Branislav Blaškovič 2012-10-11 04:43:42 EDT
I let anaconda to auto-create partitions. But then I decided to switch from LVM to Standard partition. It crashed.

Package: anaconda-18.12-1.fc18.x86_64
OS Release: Fedora release 18
Comment 17 Adam Williamson 2012-11-22 22:25:42 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.