Bug 864144 - SELinux is preventing /usr/bin/certwatch from 'write' accesses on the fifo_file /run/systemd/sessions/110.ref (deleted).
SELinux is preventing /usr/bin/certwatch from 'write' accesses on the fifo_fi...
Status: CLOSED DUPLICATE of bug 864143
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2e311e0a96442e43fe4ae2c35cf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 13:54 EDT by Nicolas Mailhot
Modified: 2012-10-09 04:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 04:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-08 13:54 EDT, Nicolas Mailhot
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-08 13:54 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2012-10-08 13:54:34 EDT
Additional info:
libreport version: 2.0.15
kernel:         3.7.0-0.rc0.git2.4.fc19.x86_64

description:
:SELinux is preventing /usr/bin/certwatch from 'write' accesses on the fifo_file /run/systemd/sessions/110.ref (deleted).
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If vous souhaitez ignorer que certwatch tente d'obtenir l'accès write à 110.ref (deleted) fifo_file car vous pensez qu'il ne devrait pas nécessiter cet accès.
:Then vous devriez rapporter ceci en tant qu'anomalie.  
:Vous pouvez générer un module de stratégie local pour dontaudit cet accès.
:Do
:# grep /usr/bin/certwatch /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If vous pensez que certwatch devrait être autorisé à accéder write sur 110.ref (deleted) fifo_file par défaut.
:Then vous devriez rapporter ceci en tant qu'anomalie.
:Vous pouvez générer un module de stratégie local pour autoriser cet accès.
:Do
:autoriser cet accès pour le moment en exécutant :
:# grep certwatch /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:certwatch_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:systemd_logind_sessions_t:s0
:Target Objects                /run/systemd/sessions/110.ref (deleted) [
:                              fifo_file ]
:Source                        certwatch
:Source Path                   /usr/bin/certwatch
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           crypto-utils-2.4.1-36.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.7.0-0.rc0.git2.4.fc19.x86_64 #1
:                              SMP Fri Oct 5 20:59:24 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    2012-10-08 03:22:03 CEST
:Last Seen                     2012-10-08 03:22:04 CEST
:Local ID                      b915b47e-6ed9-4f5f-8ba3-6797c9ac05c4
:
:Raw Audit Messages
:type=AVC msg=audit(1349659324.380:8776): avc:  denied  { write } for  pid=7172 comm="certwatch" path=2F72756E2F73797374656D642F73657373696F6E732F3131302E726566202864656C6574656429 dev="tmpfs" ino=2143403 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_logind_sessions_t:s0 tclass=fifo_file
:
:
:type=SYSCALL msg=audit(1349659324.380:8776): arch=x86_64 syscall=execve success=yes exit=0 a0=20fa8c0 a1=20fa850 a2=20fabf0 a3=8 items=0 ppid=7134 pid=7172 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=110 tty=(none) comm=certwatch exe=/usr/bin/certwatch subj=system_u:system_r:certwatch_t:s0-s0:c0.c1023 key=(null)
:
:Hash: certwatch,certwatch_t,systemd_logind_sessions_t,fifo_file,write
:
:audit2allow
:
:#============= certwatch_t ==============
:allow certwatch_t systemd_logind_sessions_t:fifo_file write;
:
:audit2allow -R
:
:#============= certwatch_t ==============
:allow certwatch_t systemd_logind_sessions_t:fifo_file write;
:
Comment 1 Nicolas Mailhot 2012-10-08 13:54:37 EDT
Created attachment 623602 [details]
File: type
Comment 2 Nicolas Mailhot 2012-10-08 13:54:39 EDT
Created attachment 623603 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-09 04:18:26 EDT

*** This bug has been marked as a duplicate of bug 864143 ***

Note You need to log in before you can comment on or make changes to this bug.