Bug 864152 - SELinux is preventing /usr/bin/freshclam from 'write' accesses on the fifo_file /run/systemd/sessions/227.ref.
SELinux is preventing /usr/bin/freshclam from 'write' accesses on the fifo_fi...
Status: CLOSED DUPLICATE of bug 864143
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d92623d384d5c330aed3e7beed1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 13:56 EDT by Nicolas Mailhot
Modified: 2012-10-09 04:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 04:19:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-08 13:56 EDT, Nicolas Mailhot
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-08 13:56 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2012-10-08 13:56:51 EDT
Additional info:
libreport version: 2.0.15
kernel:         3.7.0-0.rc0.git2.4.fc19.x86_64

description:
:SELinux is preventing /usr/bin/freshclam from 'write' accesses on the fifo_file /run/systemd/sessions/227.ref.
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If vous souhaitez ignorer que freshclam tente d'obtenir l'accès write à 227.ref fifo_file car vous pensez qu'il ne devrait pas nécessiter cet accès.
:Then vous devriez rapporter ceci en tant qu'anomalie.  
:Vous pouvez générer un module de stratégie local pour dontaudit cet accès.
:Do
:# grep /usr/bin/freshclam /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If vous pensez que freshclam devrait être autorisé à accéder write sur 227.ref fifo_file par défaut.
:Then vous devriez rapporter ceci en tant qu'anomalie.
:Vous pouvez générer un module de stratégie local pour autoriser cet accès.
:Do
:autoriser cet accès pour le moment en exécutant :
:# grep freshclam /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:freshclam_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:systemd_logind_sessions_t:s0
:Target Objects                /run/systemd/sessions/227.ref [ fifo_file ]
:Source                        freshclam
:Source Path                   /usr/bin/freshclam
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           clamav-update-0.97.6-1900.fc19.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.7.0-0.rc0.git2.4.fc19.x86_64 #1
:                              SMP Fri Oct 5 20:59:24 UTC 2012 x86_64 x86_64
:Alert Count                   10
:First Seen                    2012-10-07 15:17:05 CEST
:Last Seen                     2012-10-08 18:17:05 CEST
:Local ID                      b474105b-f406-4dca-90f9-160418dfd816
:
:Raw Audit Messages
:type=AVC msg=audit(1349713025.310:10531): avc:  denied  { write } for  pid=12715 comm="freshclam" path="/run/systemd/sessions/227.ref" dev="tmpfs" ino=2293975 scontext=system_u:system_r:freshclam_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_logind_sessions_t:s0 tclass=fifo_file
:
:
:type=SYSCALL msg=audit(1349713025.310:10531): arch=x86_64 syscall=execve success=yes exit=0 a0=1dfd960 a1=1dff390 a2=1dffef0 a3=8 items=0 ppid=12625 pid=12715 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=227 tty=(none) comm=freshclam exe=/usr/bin/freshclam subj=system_u:system_r:freshclam_t:s0-s0:c0.c1023 key=(null)
:
:Hash: freshclam,freshclam_t,systemd_logind_sessions_t,fifo_file,write
:
:audit2allow
:
:#============= freshclam_t ==============
:allow freshclam_t systemd_logind_sessions_t:fifo_file write;
:
:audit2allow -R
:
:#============= freshclam_t ==============
:allow freshclam_t systemd_logind_sessions_t:fifo_file write;
:
Comment 1 Nicolas Mailhot 2012-10-08 13:56:55 EDT
Created attachment 623616 [details]
File: type
Comment 2 Nicolas Mailhot 2012-10-08 13:56:56 EDT
Created attachment 623617 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-09 04:19:22 EDT

*** This bug has been marked as a duplicate of bug 864143 ***

Note You need to log in before you can comment on or make changes to this bug.