Bug 864170 - SAM configures the number of thin processes incorrectly
SAM configures the number of thin processes incorrectly
Status: CLOSED UPSTREAM
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello-configure (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jordan OMara
SAM QE List
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-10-08 15:05 EDT by Jordan OMara
Modified: 2014-11-09 17:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 11:53:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan OMara 2012-10-08 15:05:24 EDT
Default SAM installations incorrectly configures only 1 thin process, and during configuration /etc/httpd/conf.d/katello.conf has ZERO thin servers listed under BalancerMembers

Expected behavior:
A regular system should get 2 thin processes and both should be listed under BalancerMembers
Comment 1 Jordan OMara 2012-11-27 11:53:28 EST
Fixed upstream since bug was reported:

  <Proxy balancer://thinservers>
    BalancerMember http://127.0.0.1:5000/headpin
    BalancerMember http://127.0.0.1:5001/headpin
  </Proxy>




[root@brazillions ~]# netstat -anlp | grep thin
tcp        0      0 127.0.0.1:5000              0.0.0.0:*                   LISTEN      4280/thin server (1 
tcp        0      0 127.0.0.1:5001              0.0.0.0:*                   LISTEN      4284/thin server (1

Note You need to log in before you can comment on or make changes to this bug.