Bug 864195 - [RFE] New String: Add string to output of 'subscription-manager subscribe --auto' if can't cover all products
[RFE] New String: Add string to output of 'subscription-manager subscribe --a...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.1
Assigned To: William Poteat
John Sefler
: FutureFeature
Depends On:
Blocks: rhsm-rhel71
  Show dependency treegraph
 
Reported: 2012-10-08 16:20 EDT by Matt Reid
Modified: 2015-03-05 08:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 08:14:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-10-08 16:20:12 EDT
Description of problem:
If an auto-subscribe through the CLI fails, we don't even mention that we tried, we just say "hey, here's your product, and its not subscribed to anything", which could be a bit confusing as that's exactly what they just tried to fix.

After we list out the status of all of their installed products, it would be nice if we also had a string, saying something like "Unable to find available subscriptions for all of your installed products."

Current:
# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:      Red Hat Enterprise Linux Server
Status:            Not Subscribed

#[]


Proposed:
# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:      Red Hat Enterprise Linux Server
Status:            Not Subscribed

Unable to find available subscriptions for all of your installed products.
#[]

Version-Release number of selected component (if applicable):
subscription-manager-1.1.2-1.git

Additional Information:
Instead of doing a blanket statement at the end, we could instead show the message as part of the output for each unsubscribed product and change it to be singular.
Comment 2 William Poteat 2014-02-17 13:46:02 EST
master commit 40148ff8a1ffba7c5724dd45388aeab3b4a627ab
Comment 3 Bryan Kearney 2014-07-30 15:24:33 EDT
Acking 7.1
Comment 4 Shwetha Kallesh 2014-10-08 02:13:14 EDT
Marking verified!!

[root@localhost product]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.32-1
subscription management rules: 5.11
subscription-manager: 1.13.3-1.el7
python-rhsm: 1.13.2.1-2.el7


[root@localhost product]# subscription-manager attach --auto
Installed Product Current Status:
Product Name: Management Bits
Status:       Subscribed

Product Name: Large File Support Bits
Status:       Subscribed

Product Name: Red Hat Enterprise Linux Server
Status:       Not Subscribed

Product Name: Shared Storage Bits
Status:       Subscribed

Product Name: Awesome OS Server Bits
Status:       Subscribed

Product Name: Load Balancing Bits
Status:       Subscribed

Unable to find available subscriptions for all your installed products.
Comment 6 errata-xmlrpc 2015-03-05 08:14:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0502.html

Note You need to log in before you can comment on or make changes to this bug.