Bug 8642 - Corrupt RPM database can't be repaired (can't rebuilddb)
Summary: Corrupt RPM database can't be repaired (can't rebuilddb)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-20 01:49 UTC by Andrew Pam
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-20 02:09:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Pam 2000-01-20 01:49:52 UTC
I have had RPM databases become corrupted since RH 4.0.  It is not possible
to repair these problems, which can prevent package upgrades and
installations, and the problems are carried over into OS upgrades.
I presently have a RHL 6.1 system running rpm 3.0.3 with a corrupt
database, and since I cannot even --rebuilddb I will probably not be able
to upgrade this system to the next major version of rpm.

On this machine, rpm --rebuilddb (as root) fails with:

# rpm --rebuilddb
error getting record plhyph.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record pt8hyph.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record sehyph.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record picmore.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record pictex.sty from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record pictexwd.sty from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record prepictex.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record dvipsone.con from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record multido.sty from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record textures.con from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record vtex.con from /var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record xydvidrv.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record xyps-ps.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record xyps.tex from /var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record xyv2.tex from /var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record xyweb.tex from /var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record story.tex from /var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record testfont.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record bplain.ini from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record mtplainx.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record mtplus.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record stanacce.tex from
/var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record mktex.opt from /var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record mktexdir from /var/lib/rpmrebuilddb.840/fileindex.rpm
error getting record mktexnam from /var/lib/rpmrebuilddb.840/fileindex.rpm
cannot add record originally at 11186840
failed to rebuild database; original database remains in place

Comment 1 Andrew Pam 2000-01-20 02:09:59 UTC
rpm doesn't report out of disk space.


Note You need to log in before you can comment on or make changes to this bug.