Bug 864212 - required RAM numbers need to be revisited (again)
required RAM numbers need to be revisited (again)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 17:39 EDT by Reartes Guillermo
Modified: 2014-02-05 07:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 07:29:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the 'aberrant snapshot' of the guest, reboot is needed (79.63 KB, image/png)
2012-10-08 17:48 EDT, Reartes Guillermo
no flags Details
btrfs-3 guest (qemu xml) (6.49 KB, text/plain)
2012-10-09 10:36 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-08 17:39:58 EDT
Description of problem:

Anaconda (or xorg) appears to freeze when one select 'Development and Creativity Workstation' using 'closest mirror' as an 'Installation Source'

Version-Release number of selected component (if applicable):
F18b tc2

How reproducible:
always

Steps to Reproduce:

0- Boot and go directly to 1 leaving all defaults.

1- Select in Installation Source: 'On the network' and choose: 'Closest Mirror',
then return to the main hub

2- Wait until Software Selection becomes possible. Then enter 'Software Selection' and choose 'minimal'. Then return to the main hub and wait until 'Sofware Selection' is again accessible.

3- Enter 'Software Selection' and choose "Development and Creativity Workstation" and return to the main hub.

4- Wait... Check that anaconda is not hung. It will not, mouse hoover will change pointer, alt+tab will work, but just wait a bit. In my case i need to wait some minutes due a less than bad option-less isp :-(

Suddenly you will notice that neither alt+tab nor switching to another vt works.
At this point, anaconda/xorg/kernel is/are frozen (for practical purposes, at least). Reboot.

  
Actual results:
the guest must be rebooted

Expected results:
no issue or an error of some kind

Additional info:
Comment 1 Reartes Guillermo 2012-10-08 17:47:28 EDT
I tried this workaround, at point 4, instead of waiting, switch to another vt.
Then tail -f packaging.log. I tried this two times, with different results.

The first time, the dependencies were resolved, i switched back to anaconda, but
anaconda was heavily wounded, sluggish, i tried to access 'software selection' again and got the 'aberrant snapshot' below. Of course, anaconda has slowed and became stalled.

The second time, anaconda never finished resolving dependencies, i ctr+c the running tail and noticed the guest had become sluggish...
Top shows process loop1 is always using a minimum of 63% (to 100%) cpu time. I switch back to anaconda, but evidently the guest is kaput...

So, the common factor is something eating the cpu.
Comment 2 Reartes Guillermo 2012-10-08 17:48:56 EDT
Created attachment 623745 [details]
the 'aberrant snapshot' of the guest, reboot is needed
Comment 3 Chris Lumens 2012-10-09 10:23:29 EDT
I'm not seeing any sluggishness here.  How much memory do you have in the system in question?
Comment 4 Reartes Guillermo 2012-10-09 10:36:44 EDT
Created attachment 624121 [details]
btrfs-3 guest (qemu xml)

The guest has 768mb ram.

I will try with 2048 and post an update shortly.
Comment 5 Reartes Guillermo 2012-10-09 12:32:54 EDT
I tried this:

2048MB -> OK  (Reproduced 0 times out of 2 tries)
1024MB -> OK  (Reproduced 0 times out of 2 tries)
 768MB -> BAD (Reproduced 2 times out of 2 tries)

It seems that 768mb is not enough.

Is currently expected for anaconda to display a warning / error dialog if the
amount of memory is less than the official value?
Comment 6 Jesse Keating 2012-10-09 13:51:01 EDT
We don't at this time have a good idea as to what the memory requirements are.  A lot of it also has to do with your boot and install method.

How was this system booted, where was stage2 loaded from?
Comment 7 Reartes Guillermo 2012-10-09 14:05:32 EDT
"How was this system booted, where was stage2 loaded from?"

Using KVM/SPICE(QLX), boot from cdrom, selecting the option "install/upgrade fedora".

"We don't at this time have a good idea as to what the memory requirements are.  A lot of it also has to do with your boot and install method."

Ok, but is it there some target value for the minimum ram anaconda need? (even if it is provisional). I believe that beta should be released with a known memory requirement. (at least to setup the testing guests correctly). 

At least in this specific case, 768mb seems to be not enough.
Comment 8 Jesse Keating 2012-10-09 15:20:24 EDT
Well, I would hope that when booting from CDrom, thus loading stage2 from there instead of downloading it into ram, and using an install source on the media rather than again downloading it to disk we could manage to install graphically a system with only 768 megs of ram.  If we cant, I would consider that a bug somewhere.  Finding that and fixing that bug may be very difficult, but I do believe it would be a bug.
Comment 9 Reartes Guillermo 2012-10-09 16:01:42 EDT
Currently this bug-report shows that there is at least one example of anaconda needing 1gb. 

Certainly 768mb were enough for most common scenarios, and that is good.

1- Anaconda 'hard memory requirement' (HARD_MEM_REQ)
* Will print an error and prevent installing. (instead of behaving erratically due to low memory conditions). No bug-reports are wanted with such ram-size.
* Installing from DVD as a source (at a minimum) must work within this limit.

>> Currently it is set to 512Mb (there is an error in text mode, wich informs the user that it has not enough RAM)


2- Anaconda 'soft memory requirement' (SOFT_MEM_REQ)
* Anaconda will not prevent installing, it will print a warning instead:
"You have less than SOFT_MEM_REQ of RAM, some features might not work or might work incorrectly/erratically. Please try with more RAM first before filling a bug-report"

>> Not sure if anaconda supports this, but currently any ram-size less than 1GB should print a warning. This is mostly to improve bug-reporting.
Comment 10 Reartes Guillermo 2012-10-09 22:07:33 EDT
I repeated the test with F18b TC3 and it fails the same with 768mb and works with 1Gb.
Comment 11 Reartes Guillermo 2012-10-24 17:34:38 EDT
I repeated the test with F18b TC6 and it fails the same with 768mb
Comment 12 Reartes Guillermo 2013-01-08 14:39:19 EST
I repeated the test with F18 RC2 (18.37.11) and it fails the same with 768mb
This probably should be added to the release notes.
Comment 13 Fedora End Of Life 2013-12-21 04:04:30 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 14 Fedora End Of Life 2014-02-05 07:30:02 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.