Bug 864218 - SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the directory /var/tmp.
SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the director...
Status: CLOSED DUPLICATE of bug 864219
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e8fd2a290593edb521d6c082df5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 18:06 EDT by Flóki Pálsson
Modified: 2012-10-09 04:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 04:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-08 18:06 EDT, Flóki Pálsson
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-08 18:06 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2012-10-08 18:06:33 EDT
Description of problem:
starting s-c-samba

Additional info:
libreport version: 2.0.15
kernel:         3.6.0-3.fc18.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the directory /var/tmp.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed read access on the tmp directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep system-config-s /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:sambagui_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:tmp_t:s0
:Target Objects                /var/tmp [ dir ]
:Source                        system-config-s
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-13.fc18.x86_64
:Target RPM Packages           filesystem-3.1-2.fc18.x86_64
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-3.fc18.x86_64 #1 SMP Wed Oct
:                              3 13:29:15 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    2012-10-08 22:01:29 GMT
:Last Seen                     2012-10-08 22:03:43 GMT
:Local ID                      9fb04dfc-d2c7-410e-a015-5929d16fb4e7
:
:Raw Audit Messages
:type=AVC msg=audit(1349733823.913:239): avc:  denied  { read } for  pid=18917 comm="system-config-s" name="tmp" dev="sda3" ino=262164 scontext=system_u:system_r:sambagui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmp_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1349733823.913:239): arch=x86_64 syscall=open success=no exit=EACCES a0=3032e42603 a1=0 a2=1b6 a3=238 items=0 ppid=18916 pid=18917 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=system-config-s exe=/usr/bin/python2.7 subj=system_u:system_r:sambagui_t:s0-s0:c0.c1023 key=(null)
:
:Hash: system-config-s,sambagui_t,tmp_t,dir,read
:
:audit2allow
:
:#============= sambagui_t ==============
:allow sambagui_t tmp_t:dir read;
:
:audit2allow -R
:
:#============= sambagui_t ==============
:allow sambagui_t tmp_t:dir read;
:
Comment 1 Flóki Pálsson 2012-10-08 18:06:36 EDT
Created attachment 623765 [details]
File: type
Comment 2 Flóki Pálsson 2012-10-08 18:06:39 EDT
Created attachment 623766 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-09 04:23:56 EDT

*** This bug has been marked as a duplicate of bug 864219 ***

Note You need to log in before you can comment on or make changes to this bug.