Bug 86422 - restest locks up with server grab
restest locks up with server grab
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-21 14:38 EST by Owen Taylor
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 12:17:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2003-03-21 14:38:43 EST
The restest.c test program that was incorporated into
our X packages does printf()'s inside XGrabServer().

This is real bad, because printf() can block on the
terminal emulator, which is blocking on the server,
so the X session hangs with a server grab.
 
The program needs to retrieve everything, store it,
ungrab the server, XFlush(TheDisplay), then print
stuff out.

(If you don't XFlush(), then the server probably won't
get the ungrab.)
Comment 1 Mike A. Harris 2003-04-03 17:36:40 EST
bliz: Is this possibly what you were seeing eons ago?
Comment 2 Christopher Blizzard 2003-04-09 00:10:32 EDT
No, I don't think so.
Comment 3 Owen Taylor 2003-04-09 10:44:59 EDT
Reopening, since there is nothing NEEDINFO here any more.
Comment 4 Mike A. Harris 2004-09-23 12:17:12 EDT
We ship xrestop now, which supercedes the 'restest' hack MarkV
wrote.  Setting status to "CURRENTRELEASE" of FC2 with xrestop

Note You need to log in before you can comment on or make changes to this bug.