Bug 864262 - Remmina-1.0.0.-4.fc17: Windows minimized on dual monitor systems can't be accessed.
Summary: Remmina-1.0.0.-4.fc17: Windows minimized on dual monitor systems can't be ac...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: remmina
Version: 17
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-09 01:59 UTC by Steve Foster
Modified: 2013-05-24 20:45 UTC (History)
1 user (show)

Fixed In Version: remmina-1.0.0-7.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-19 02:41:14 UTC


Attachments (Terms of Use)

Description Steve Foster 2012-10-09 01:59:48 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Christoph Wickert 2012-10-09 07:16:55 UTC
Can you please elaborate the problem a little?

Comment 2 Steve Foster 2012-10-09 15:36:45 UTC
(In reply to comment #0)
> Description of problem:
> Remmina vers 8.x till the current versions
> 
> Version-Release number of selected component (if applicable):
> ver. 8.x till the current vers 1.0.0-4
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1) Install remmina on dual screen fedora system.

> 2) Connect to any rdp enabled windows system.  

> 3) Enlarge RDP or VNC window to maximum size or Full screen ( no border).

   4) Now use Minimize or ctrl_R + F9 key.
>   
> Actual results:
> You can't restore that window to view, in fact it is not even visible.
> 
> Expected results:
> On a single monitor system the minimized window to view and may restore it to the screen.
> 
> Additional info:

Comment 3 Steve Foster 2012-10-09 15:37:45 UTC
PS 

Dos not matter if you use the Opensource X drivers or the Nividia drivers.

Comment 4 Steve Foster 2012-10-09 15:42:36 UTC
Also if you google for this, the bug has been around over a year or two

Comment 5 Christoph Wickert 2012-10-09 17:32:13 UTC
I'm sorry, I still don't get it. What desktop environment or window manager are you using? What is your multiscreen setup?

Please give me the output of the command 'xrandr'.

Comment 6 Steve Foster 2012-12-27 07:26:41 UTC
gnome-shell with dual monitors. Bug is well documented, fixes are in latest github, and I can't compile the damn thing for F17, because to developers are using later libs than are available in fedora.

Comment 7 Christoph Wickert 2012-12-27 09:13:31 UTC
Can you point me to the relevant commits or an upstream bug report?

Comment 8 Steve Foster 2013-04-13 23:39:57 UTC
GitHub Patches that talk about this bug/patch

https://github.com/dupondje/Remmina

Comment 9 Steve Foster 2013-04-14 00:19:45 UTC
OpenSuse has a source rpm with the Monitor Patch built in -

http://download.opensuse.org/factory/repo/src-oss/suse/src/remmina-1.0.0-8.1.src.rpm

Comment 10 Fedora Update System 2013-05-07 00:58:58 UTC
remmina-1.0.0-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/remmina-1.0.0-7.fc19

Comment 11 Fedora Update System 2013-05-07 00:59:30 UTC
remmina-1.0.0-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/remmina-1.0.0-7.fc18

Comment 12 Fedora Update System 2013-05-07 01:00:22 UTC
remmina-1.0.0-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/remmina-1.0.0-7.fc17

Comment 13 Fedora Update System 2013-05-07 20:44:41 UTC
Package remmina-1.0.0-7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing remmina-1.0.0-7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7586/remmina-1.0.0-7.fc19
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2013-05-19 02:41:14 UTC
remmina-1.0.0-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2013-05-19 02:42:24 UTC
remmina-1.0.0-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2013-05-24 20:45:50 UTC
remmina-1.0.0-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.