Bug 864297 - Text Flow Target History contains an entry for the initial empty string
Text Flow Target History contains an entry for the initial empty string
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
development
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.0
Assigned To: Carlos Munoz
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 00:28 EDT by Carlos Munoz
Modified: 2013-02-25 22:46 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121119-0019)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Munoz 2012-10-09 00:28:25 EDT
Description of problem:
Text Flow target history contains an empty entry after an initial save.


Version-Release number of selected component (if applicable):
1.8-SNAPSHOT

How reproducible:
Always (found on a po project with plurals)


Steps to Reproduce:
1. Try to edit a text flow on any project.
2. Visit the History screen.
  
Actual results:
There is an entry in the history screen for an initial "empty" state. This entry cannot be copied into the editor.

Expected results:
There should only be a single history entry after the initial save. One for the current latest state.
Comment 1 Carlos Munoz 2012-11-08 19:40:21 EST
This was caused by an incorrect use of Hibernate entity listeners. The new implementation uses DB triggers again. Please retest.
Comment 2 Sean Flanigan 2012-11-08 21:30:16 EST
This change is in the current release (2.0.2), isn't it?  So if we verify it, it can move straight to 'closed'.
Comment 3 Carlos Munoz 2012-11-08 21:39:31 EST
That's right, this is already in 2.0.2.
Comment 4 Ding-Yi Chen 2012-11-18 23:42:13 EST
VERIFIED 
with Zanata version 2.1-SNAPSHOT (20121119-1207)
and Zanata version 2.0.3-SNAPSHOT (20121119-0019)

Note You need to log in before you can comment on or make changes to this bug.