Bug 864300 - traps: NetworkManager[627] general protection ip:47101ce0 sp:bffc3ec0 error:0 in libglib-2.0.so.0.3400.0[4709e000+129000]
Summary: traps: NetworkManager[627] general protection ip:47101ce0 sp:bffc3ec0 error:0...
Keywords:
Status: CLOSED DUPLICATE of bug 865009
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-09 04:30 UTC by Mikhail
Modified: 2012-10-17 08:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-17 08:20:52 UTC


Attachments (Terms of Use)

Description Mikhail 2012-10-09 04:30:21 UTC
Description of problem:
traps: NetworkManager[627] general protection ip:47101ce0 sp:bffc3ec0 error:0 in libglib-2.0.so.0.3400.0[4709e000+129000]

also

traps: NetworkManager[2504] general protection ip:47101ce0 sp:bfa31b50 error:0 in libglib-2.0.so.0.3400.0[4709e000+129000]

Comment 1 Mikhail 2012-10-09 05:09:49 UTC
also 

traps: NetworkManager[3518] general protection ip:47101ce0 sp:bffdd280 error:0 in libglib-2.0.so.0.3400.0[4709e000+129000]


And occurs after each unlock computer

Comment 2 Neil Darlow 2012-10-09 10:06:50 UTC
I've been seeing these too associated with KDE's Network Management applet mis-behaving. Typical output from dmesg is:

[   58.385920] traps: NetworkManager[627] general protection ip:4f55ece0 sp:bfb9cfb0 error:0 in libglib-2.0.so.0.3400.0[4f4fb000+129000]

[   97.235344] traps: NetworkManager[1337] general protection ip:4f55ece0 sp:bfd69880 error:0 in libglib-2.0.so.0.3400.0[4f4fb000+129000]

[  151.777085] traps: gdbus[1483] general protection ip:4f55ece0 sp:b6befdd0 error:0 in libglib-2.0.so.0.3400.0[4f4fb000+129000]

[ 1566.621543] traps: gdbus[2175] general protection ip:4f55ece0 sp:b6c09bb0 error:0 in libglib-2.0.so.0.3400.0[4f4fb000+129000]

Comment 3 Jirka Klimes 2012-10-16 08:52:08 UTC
What is your NM version?
Could you try if https://admin.fedoraproject.org/updates/NetworkManager-0.9.7.0-6.git20121004.fc18 fixes the problem?

Comment 4 Neil Darlow 2012-10-16 09:25:42 UTC
I think it was NetworkManager-0.9.7.0-4.git20121004 but I've just updated to the version you noted here based on its changelog entries.

Currently testing and looking good so far but this is with kernel-PAE-3.6.0-5 due to 3.6.1-1 exhibiting some instability with NetworkManager. If NetworkManager looks stable I'll update the kernel to 3.6.1-1 again and report back.

Comment 5 Neil Darlow 2012-10-16 17:07:54 UTC
I've been using this system with kernel-3.6.0-5 and 3.6.1-1 (a half day of each) and have not experienced a single NetworkManager crash.

It looks like NetworkManager-0.9.7.0-6.20121004.fc18 is a solid fix for these problems.

The effect noted on kernel-3.6.1-1 and ath5k/ath9k where NetworkManager would repeatedly prompt for a network secret (for a system connection with stored secret) is also fixed. This problem also affects fc17 and would be worth back-porting to its version of NetworkManager.

Comment 6 Jirka Klimes 2012-10-17 08:20:52 UTC
Neil, thanks for verifying. So I'm duping this to bug 865009.

Should you have an instability with ath5k/ath9 drivers, consider opening a bug against kernel.

*** This bug has been marked as a duplicate of bug 865009 ***


Note You need to log in before you can comment on or make changes to this bug.