Bug 864322 - Invalid macro definition in glibc-headers
Summary: Invalid macro definition in glibc-headers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc
Version: 6.3
Hardware: All
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Jeff Law
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-09 07:06 UTC by Valentine Sinitsyn
Modified: 2016-11-24 16:02 UTC (History)
2 users (show)

Fixed In Version: glibc-2.12-1.104.el6
Doc Type: Bug Fix
Doc Text:
Cause: The definition of IPTOS_CLASS referenced referenced the wrong object. Consequence: Applications built which referenced IPTOS_CLASS from ip.h may not build. If they build they may not operate correctly. Fix: The definition of IPTOS_CLASS was fixed to reference the right object. Result: Applications which reference IPTOS_CLASS from ip.h should build and work correctly.
Clone Of:
Environment:
Last Closed: 2013-02-21 07:06:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch that fixes the problem (364 bytes, patch)
2012-10-09 08:31 UTC, Valentine Sinitsyn
no flags Details | Diff
More accurate version of the same trivial patch (363 bytes, patch)
2012-10-09 08:32 UTC, Valentine Sinitsyn
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0279 normal SHIPPED_LIVE glibc bug fix and enhancement update 2013-02-20 20:37:06 UTC

Description Valentine Sinitsyn 2012-10-09 07:06:17 UTC
Description of problem:

netinet/ip.h contains incorrect macro definition:

#define IPTOS_CLASS(class) ((tos) & IPTOS_CLASS_MASK)

Being expanded, this macro always results in ((tos) & IPTOS_CLASS_MASK), regardless what the argument (class) is.

Version-Release number of selected component (if applicable):
glibc-headers 2.12

How reproducible:
Always

Steps to Reproduce:
1. #include <netinet/ip.h>
2. Define struct iphdr iph;
3. Try to evaluate IPTOS_PREC(iph.tos)
  
Actual results:
Compilation error is issued:
error: ‘tos’ undeclared (first use in this function)

Expected results:
The program compiles okay.

Additional info:
None

Comment 2 Valentine Sinitsyn 2012-10-09 08:31:04 UTC
Created attachment 623975 [details]
Proposed patch that fixes the problem

Comment 3 Valentine Sinitsyn 2012-10-09 08:32:14 UTC
Created attachment 623977 [details]
More accurate version of the same trivial patch

Comment 6 errata-xmlrpc 2013-02-21 07:06:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0279.html


Note You need to log in before you can comment on or make changes to this bug.