Bug 864341 - [abrt] gnome-clocks-0.1.3-2.fc18: locale.py:539:setlocale:Error: unsupported locale setting
[abrt] gnome-clocks-0.1.3-2.fc18: locale.py:539:setlocale:Error: unsupported ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-clocks (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Yanko Kaneti
Fedora Extras Quality Assurance
abrt_hash:7f9e4c203e8151b57bc8cf91f12...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 04:09 EDT by Kamil Páral
Modified: 2012-12-20 10:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:04:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (30 bytes, text/plain)
2012-10-09 04:09 EDT, Kamil Páral
no flags Details
File: core_backtrace (167 bytes, text/plain)
2012-10-09 04:09 EDT, Kamil Páral
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 685791 None None None 2012-10-09 04:53:23 EDT

  None (edit)
Description Kamil Páral 2012-10-09 04:09:53 EDT
Description of problem:
I just tried to run the app

Version-Release number of selected component:
gnome-clocks-0.1.3-2.fc18

Additional info:
libreport version: 2.0.15
abrt_version:   2.0.14
cmdline:        /usr/bin/python /usr/bin/gnome-clocks
kernel:         3.6.0-3.fc18.i686.PAE

backtrace:
:locale.py:539:setlocale:Error: unsupported locale setting
:
:Traceback (most recent call last):
:  File "/usr/bin/gnome-clocks", line 50, in <module>
:    locale.setlocale(locale.LC_ALL, '')
:  File "/usr/lib/python2.7/locale.py", line 539, in setlocale
:    return _setlocale(category, locale)
:Error: unsupported locale setting
:
:Local variables in innermost frame:
:locale: ''
:category: 6
Comment 1 Kamil Páral 2012-10-09 04:09:56 EDT
Created attachment 623959 [details]
File: dso_list
Comment 2 Kamil Páral 2012-10-09 04:09:58 EDT
Created attachment 623960 [details]
File: core_backtrace
Comment 3 Yanko Kaneti 2012-10-09 04:53:23 EDT
With the current code not much else is expected when you try an invalid/notinstalled locale. 
I've filed this upstream for final resolution  https://bugzilla.gnome.org/show_bug.cgi?id=685791
Comment 4 Yanko Kaneti 2012-10-09 05:02:50 EDT
Upstream accepted a patch to avoid crashing. Since this is a isolated incident caused by some local locale miss-configuration I'll hold on with the fix entering fedora for the next version bump.
Comment 5 Yanko Kaneti 2012-10-09 05:11:12 EDT
Kamil, if your F18 installation ended up in a situation where
>> import locale
>> locale.setlocale(locale.LC_ALL, '')
doesn't work, then this should be investigated separately.
Comment 6 Kamil Páral 2012-10-09 05:18:11 EDT
Hello, I'm quite sure this is caused by current anaconda bug 858591. That will have to be fixed for sure, so this crash should not appear so often.

But still, the application shouldn't crash if the user has invalid locale, but fallback to C or en_US.utf8 locale instead.
Comment 7 Yanko Kaneti 2012-10-09 05:22:21 EDT
(In reply to comment #6)
> But still, the application shouldn't crash if the user has invalid locale,
> but fallback to C or en_US.utf8 locale instead.

Yup. When I said version bump I meant gnome-clocks version bump, then filing an update for f18
Comment 8 Amit Shah 2012-10-11 03:21:34 EDT
Start 'Clocks' on a fresh install, got crash.

Package: gnome-clocks-0.1.3-2.fc18
Architecture: x86_64
OS Release: Fedora release 18 (Spherical Cow)
Comment 9 Fedora Update System 2012-10-16 03:00:26 EDT
gnome-clocks-0.1.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-clocks-0.1.4-1.fc18
Comment 10 Fedora Update System 2012-10-16 13:41:33 EDT
Package gnome-clocks-0.1.4-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-clocks-0.1.4-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16220/gnome-clocks-0.1.4-1.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-12-20 10:04:28 EST
gnome-clocks-0.1.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.