Bug 864429 - improper content of docfiles in /usr/share/setroubleshoot
Summary: improper content of docfiles in /usr/share/setroubleshoot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: setroubleshoot
Version: 6.4
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact: Michal Trunecka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-09 12:26 UTC by Michal Trunecka
Modified: 2014-09-30 23:33 UTC (History)
2 users (show)

Fixed In Version: setroubleshoot-3.0.47-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:05:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0387 normal SHIPPED_LIVE setroubleshoot bug fix update 2013-02-20 20:51:50 UTC

Description Michal Trunecka 2012-10-09 12:26:47 UTC
Description of problem:
Is there a reason to have files like these in the released rpm?

# cat /usr/share/doc/setroubleshoot-3.0.47/README
FIXME: need to author this
# cat /usr/share/doc/setroubleshoot-3.0.47/NEWS
FIXME: need to author this

Also /usr/share/doc/setroubleshoot-3.0.47/TODO conatains TODO list with assigned developers, which I think shouldn't be there either.


Version-Release number of selected component (if applicable):
setroubleshoot-server-3.0.47-4.el6.x86_64

How reproducible:
always


Expected results:
Content fixed or files removed.

Additional info:

Comment 2 Daniel Walsh 2012-10-09 16:07:49 UTC
I agree we should just drop this package.

Nothing in here is up2date.

Comment 3 Miroslav Grepl 2012-10-15 12:29:17 UTC
Fixed in setroubleshoot-3.0.47-5.el6

Comment 5 RHEL Program Management 2012-10-15 12:51:36 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 8 Michal Trunecka 2012-10-18 12:30:59 UTC
There is also ChangeLog file /usr/share/doc/setroubleshoot-3.0.47/ChangeLog where the last record is dated 2010-11-9, which I guess is not much up to date. e.g. following record is missing:

* Thu Jun 14 2012 <dwalsh@redhat.com> - 3.0.47-3 - Sedispatch is not handling audit messages correctly, this fix allows setroubleshoot to process alerts. Resolves: #575686


And just for sure, the TODO file is meant to be there?

Comment 11 Miroslav Grepl 2012-11-19 09:42:30 UTC
I fixed Changelog file but I don't see any problems with TODO to keep it.

Comment 18 errata-xmlrpc 2013-02-21 10:05:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0387.html


Note You need to log in before you can comment on or make changes to this bug.