Bug 864457 - conductor prefers the provider accounts defined with the highest priority value, instead of lowest
conductor prefers the provider accounts defined with the highest priority val...
Status: CLOSED NOTABUG
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Angus Thomas
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 08:40 EDT by Giulio Fidente
Modified: 2012-10-23 11:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 11:11:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio Fidente 2012-10-09 08:40:58 EDT
Description of problem:
when launching an application, if conductor is let to choose the provider to be used, it prefers the provider account defined with the highest number in the priority field, instead of the lowest, as assumed by the user guide.


Version-Release number of selected component (if applicable):
aeolus-conductor-0.13.16-1.el6cf


Steps to Reproduce:
1. configure at least two different provider accounts and set two different priority values (say 1 and 2)
2. launch an application letting conductor to auto-select the target cluster 
3. observe conductor preferring the account with the highest value set
  

Additional info:
Comment 1 Giulio Fidente 2012-10-15 11:11:17 EDT
this has to be updated in the doc, not in the software, as per bug 
#843807
Comment 2 Imre Farkas 2012-10-23 11:01:15 EDT
The provider selection during deployment launch has changed a lot since 1.0. In 1.1 we are randomly picking from the set of available provider accounts. The priority attribute is only used for the weight of the random selection.

So you cannot conclude that the provider account with the higher priority will be selected, or the one with the lower priority. Since it's based on random selection it can happen either way.

Note You need to log in before you can comment on or make changes to this bug.