Bug 86447 - GRUB prompt never appears when console redirection enabled
GRUB prompt never appears when console redirection enabled
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-22 00:15 EST by Dave Hansen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-22 00:50:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Hansen 2003-03-22 00:15:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT)

Description of problem:
This is an IBM x440.  It has an integrated Service Processor which allows a user
to view the text console remotely, and interact with it to do things like enter
the BIOS. 

If this redirection is enabled, the GRUB prompt never appears, and the machine
hangs.  If the Redhat-specific "splashimage=" line is removed from grub.conf, it
functions like expected.


Version-Release number of selected component (if applicable):
grub-0.92-7

How reproducible:
Always

Steps to Reproduce:
1. have "splashimage=" in your grub.conf
2. get into the Service Processor
3. reboot
4. wait for SCSI BIOS, etc to go by
5. machine freezes
    

Actual Results:  the machine is hung and must be power-cycled

Expected Results:  the grub prompt should appear

Additional info:
Comment 1 Jeremy Katz 2003-03-22 00:50:52 EST
This is because the direct vga16 access used for the grub graphics is not
handled by the console redirection.
Comment 2 Dave Hansen 2003-03-22 01:04:02 EST
Would this be prudent to add to the release notes?  The x440 is listed as RH
certified hardware.  

Note You need to log in before you can comment on or make changes to this bug.