Bug 864487 - rhevm-migration: we cannot use an existing directory for windows backup when running rhevm-migrate-windows.ps1
rhevm-migration: we cannot use an existing directory for windows backup when ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-migration (Show other bugs)
3.0.7
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Juan Hernández
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 09:00 EDT by Dafna Ron
Modified: 2016-04-18 02:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 10:54:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dafna Ron 2012-10-09 09:00:20 EDT
Description of problem:

when I ran rhevm-migrate-windows.ps1 on the windows machine (2.2) I was asked to give a full path for the temporary directory. 
this to me meant that I need to create a directory (lets say c:\tmp\migration) and give that end point directory in the script. 
as it turns out we need to give a directory which does not exist for example c:\tmp\migration\backup (where backup directory does not yet exist)

the guide even says that it makes a copy of the directory selected: 

this script makes a backup of the SQL Server database and copies other important files to the backup directory that you selected 

Version-Release number of selected component (if applicable):

2.2

How reproducible:

100%

Steps to Reproduce:
1. run rhevm-migrate-windows.ps1
2. give the tool an existing dir (full path)
3. 
  
Actual results:

we get an error: 

The directory "C:\migration\backup" already exists.

Expected results:

we should be able to select a directory (which means giving the pull path)
or fix documentation to explain that the target directory will be created by the script so we should give a path+directory and backup name


Additional info:
Comment 1 Juan Hernández 2012-10-10 10:54:51 EDT
The tool prints the following message right before asking for the location of the directory:

--
The backup of the database and some other important files that need to be
copied to the Linux machine will be stored in a temporary directory that will
be created for you. Please provide the full path for that temporary directory
below:
--

I think that the tool already does effort enough to make sure that the user understands that the directory will be created, and it also complains when the directory exists.

I am not against improving the documentation, so I am closing with the "requires_doc_text" flag.

Note You need to log in before you can comment on or make changes to this bug.