Bug 864497 - SELinux is preventing /usr/bin/qemu-kvm from 'create' accesses on the rawip_socket .
SELinux is preventing /usr/bin/qemu-kvm from 'create' accesses on the rawip_s...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2c7d112cd01cc33e3a1a66d93cb...
:
: 890555 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 09:12 EDT by Pascal Hartig
Modified: 2012-12-27 14:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 09:15:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-09 09:12 EDT, Pascal Hartig
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-09 09:12 EDT, Pascal Hartig
no flags Details

  None (edit)
Description Pascal Hartig 2012-10-09 09:12:33 EDT
Description of problem:
Pinging the LAN ip address from within the box vm causes this SE alert.

Additional info:
libreport version: 2.0.14
kernel:         3.5.4-2.fc17.x86_64

description:
:SELinux is preventing /usr/bin/qemu-kvm from 'create' accesses on the rawip_socket .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that qemu-kvm should be allowed create access on the  rawip_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep qemu-kvm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:svirt_t:s0:c656,c675
:Target Context                system_u:system_r:svirt_t:s0:c656,c675
:Target Objects                 [ rawip_socket ]
:Source                        qemu-kvm
:Source Path                   /usr/bin/qemu-kvm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           qemu-system-x86-1.0.1-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-149.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.4-2.fc17.x86_64 #1 SMP Wed Sep
:                              26 21:58:50 UTC 2012 x86_64 x86_64
:Alert Count                   5
:First Seen                    2012-10-09 15:10:20 CEST
:Last Seen                     2012-10-09 15:10:24 CEST
:Local ID                      8fd31fa0-3a35-4a5a-994f-a43eda94b177
:
:Raw Audit Messages
:type=AVC msg=audit(1349788224.959:131): avc:  denied  { create } for  pid=22718 comm="qemu-kvm" scontext=system_u:system_r:svirt_t:s0:c656,c675 tcontext=system_u:system_r:svirt_t:s0:c656,c675 tclass=rawip_socket
:
:
:type=SYSCALL msg=audit(1349788224.959:131): arch=x86_64 syscall=socket success=no exit=EACCES a0=2 a1=80002 a2=1 a3=a8 items=0 ppid=1 pid=22718 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=qemu-kvm exe=/usr/bin/qemu-kvm subj=system_u:system_r:svirt_t:s0:c656,c675 key=(null)
:
:Hash: qemu-kvm,svirt_t,svirt_t,rawip_socket,create
:
:audit2allow
:
:#============= svirt_t ==============
:allow svirt_t self:rawip_socket create;
:
:audit2allow -R
:
:#============= svirt_t ==============
:allow svirt_t self:rawip_socket create;
:
Comment 1 Pascal Hartig 2012-10-09 09:12:36 EDT
Created attachment 624098 [details]
File: type
Comment 2 Pascal Hartig 2012-10-09 09:12:38 EDT
Created attachment 624099 [details]
File: hashmarkername
Comment 3 Pascal Hartig 2012-10-09 09:15:43 EDT
Just read that ICMP is not possible from within guests using the user network. [0]


[0] http://wiki.qemu.org/Documentation/Networking
Comment 4 Miroslav Grepl 2012-12-27 14:17:32 EST
*** Bug 890555 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.