Bug 864508 - Service level {0} is not available to consumers....
Service level {0} is not available to consumers....
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: William Poteat
Katello QA List
: Regression
: 871335 876422 (view as bug list)
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-10-09 09:25 EDT by John Sefler
Modified: 2015-05-14 12:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-29 15:05:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-10-09 09:25:18 EDT
Description of problem:
A string substitution is not happening for the servicelevel into the candlepin msgid "Service level {0} is not available to consumers of organization {1}."

This is a regression.

Version-Release number of selected component (if applicable):
[root@jsefler-59server ~]# rpm -q subscription-manager
subscription-manager-1.0.21-1.git.17.8374bf1.el5
[root@jsefler-f14-candlepin po]# git show-ref | grep master
0ceb1369b0603966a3da99c272ffc0df09c7251b refs/heads/master
0ceb1369b0603966a3da99c272ffc0df09c7251b refs/remotes/origin/master


How reproducible:


Steps to Reproduce:
[root@jsefler-59server ~]# subscription-manager register --username testuser1 --org admin --servicelevel=FOO --autosubscribe
Password: 
The system has been registered with id: 8e405914-5106-4d5a-8b75-fff46b824f43 
Service level {0} is not available to consumers of organization admin.

  
Expected results:
Service level FOO is not available to consumers of organization admin.
Comment 1 William Poteat 2012-10-25 11:44:46 EDT
master commit a09b087c627e755da4382b4b26f0395cf9a3aea7
Comment 2 Bryan Kearney 2012-10-30 13:43:34 EDT
*** Bug 871335 has been marked as a duplicate of this bug. ***
Comment 3 Bryan Kearney 2012-11-15 13:24:34 EST
*** Bug 876422 has been marked as a duplicate of this bug. ***
Comment 4 Shwetha Kallesh 2013-03-13 05:12:41 EDT
Verifying version:
[root@rhel7 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.7.25-1
subscription-manager: 1.8.4-1.el7
python-rhsm: 1.8.7-1.el7


[root@rhel7 ~]# subscription-manager register --username testuser1 --org admin --servicelevel=FOO --autosubscribe
Password: 
The system has been registered with id: f6c38bc6-1206-48e1-9050-45263c4b1f4b 
Service level 'FOO' is not available to consumers of organization admin.
Comment 5 Bryan Kearney 2014-09-29 15:05:09 EDT
These bugs were fixed during 7.0 but not moved to CLOSED. They have been delivered

Note You need to log in before you can comment on or make changes to this bug.