Bug 864510 - rhevm-migration: migration fails on etl if SQL server database entered is different from backup files
rhevm-migration: migration fails on etl if SQL server database entered is dif...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-migration (Show other bugs)
3.0.7
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Juan Hernández
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 09:26 EDT by Dafna Ron
Modified: 2016-04-18 02:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 10:59:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
all install logs until I succeeded. (337.90 KB, application/x-gzip)
2012-10-09 09:26 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-10-09 09:26:22 EDT
Created attachment 624103 [details]
all install logs until I succeeded.

Description of problem:

when running rhevm-migration it was unclear to me that unless we manually created the db backup (instead of running the windoes tool) the SQL database should always be the default: rhevm_migration. 
since we are asked to give the 2.2 windows machine I was assuming that we are connecting directly to the 2.2 database and there for gave it the 2.2 db name. 

also, before running the etl we run a check on files copied from windows: 

Checking files copied from Windows ...

and we continue with the migration which will fail since the db name is incorrect. 

Version-Release number of selected component (if applicable):

3.0

How reproducible:

100%

Steps to Reproduce:
1. run migration tool and give a db name rhevm instead of default one
2.
3.
  
Actual results:

etl will fail since we are always expecting the rhevm_migration name for the SQL database. 

Expected results:

we should wither perform a check or/and add to documentation that unless we manually copied the db with a different name the windows tool will always give the db the rhevm_migration name. 

Additional info:

SQL Server host: 10.35.113.38
SQL Server port [1433]: 
SQL Server database [rhevm_migration]: 
SQL Server user [sa]: 
SQL Server password [********]: 

We need to know the details to connect to the PostgreSQL
database. Make sure that the database is started and confirm or
change the details below:

PostgreSQL host [localhost]: 
PostgreSQL port [5432]: 
PostgreSQL database [rhevm]: 
PostgreSQL user [postgres]: 
PostgreSQL password [********]: 
Checking connection to the SQL Server database at host "10.35.113.38" and port 1433 ...
Checking the status of the PostgreSQL service ...
Checking connection to the PostgreSQL database at host "localhost" and port 5432 ...
Checking files copied from Windows ...
Checking CA certificate ...
Decrypting SSH key ...
Loading hosts list ...
Checking hosts ...
Checking host "gold-vdsc" ...
Checking host "gold-vdsd" ...
Comment 1 Juan Hernández 2012-10-10 10:59:08 EDT
The Windows and Linux sides of the tool already provide "rhevm_migration" as the default name, so they are in sync. We provide the option to override it because the user may want to do the backup manually, instead of using the tool (not that usual).

Note You need to log in before you can comment on or make changes to this bug.