Bug 864552 - Chapter 9. Monitoring Enterprise Web Server with JBoss Operating Network
Chapter 9. Monitoring Enterprise Web Server with JBoss Operating Network
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-Installation-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 10:53 EDT by Jan Martiska
Modified: 2012-11-08 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:11:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2012-10-09 10:53:23 EDT
9.1:
====================================================
useradd -G tomcat,apache <RHQ_AGENT_USER>
this adds a user, but fails if you just want to add groups to an existing user, it should better be usermod -aG tomcat,apache <RHQ_AGENT_USER>



9.2:
====================================================
solaris - wrong path prefix: /opt/redhat/ews -> /opt/jboss-ews-2.0

For further information about JBoss Operating Network refer to the Discovery chapter of the Basic Administration Guide. 
-----> this links to JON 2.4 documentation, JON 2.4 does not support EWS. I tried searching for a suitable alternative in JON 3.1 docs, but didn't find any..
Comment 1 gsheldon 2012-10-09 18:39:43 EDT
updated with changes.
Removed link to JON 2.4 documentation.
Comment 3 Jan Martiska 2012-10-10 06:20:11 EDT
I completely missed the most visible mistake :D 
JON is JBoss Operations Network, not JBoss Operating Network, please change the chapter's title.
Comment 4 Jan Martiska 2012-10-10 07:09:13 EDT
another thing - the note in the bottom (Path to the HTTP Server)..
I am not aware of anything like this, where did you get this information from? I think it is not true (but I might be mistaken, I don't know that much about this matter)
Comment 5 Jan Martiska 2012-10-10 08:17:18 EDT
Sorry for splitting my comments into so many, but I find the issues over time during other tasks :) ..

JAVA_OPTS="${JAVA_OPTS} -Dcom.sun.management.jmxremote.port=PORT_NUMBER"

this should also include another property: "-Djava.rmi.server.hostname=IP_ADDRESS"

(substituting IP_ADDRESS with the address where tomcat is running) - this is probably needed in most cases in order to rhq agent to be able to connect.

also the same change goes for the windows version.
Comment 6 Jan Martiska 2012-10-10 08:30:59 EDT
A paragraph like this should be added after the part where remote-jmx port is defined for tomcat side:

After setting the remote-jmx port on tomcat side, the JBoss Operations Network agent needs information on how to connect there. After you add tomcat to the inventory, open its "Connection settings" tab in JON web interface and set the value of "Manager URL" property to the RMI URL where tomcat is available, for example service:jmx:rmi:///jndi/rmi://$IP_ADDRESS:$PORT/jmxrmi. Only after that the Tomcat resource will appear as fully 'available' in JON.
Comment 7 Misha H. Ali 2012-10-10 20:33:21 EDT
Not a problem, Jan. Thank you for your comments. I've sorted them into a list below so we can ensure we don't miss any:

1. JBoss Operating Network typos (c#3).

This is fixed in two locations. A link to verify this will be added.

2. Note: Path to the HTTP Server (c#4)

This is a legacy from 1.x docs, I'm not sure who the source for this is. As a stopgap, I am removing this from the docs. We can bring this up post 2.0 once we have the time to test this and confirm how correct the information is. This should no longer be in the docs.

3. Add "-Djava.rmi.server.hostname=IP_ADDRESS" to the command (c#5) JAVA_OPTS="${JAVA_OPTS} -Dcom.sun.management.jmxremote.port=PORT_NUMBER" for:

 a. RHEL/Solaris (in JON chapter)
 b. Windows (in JON Chapter)

This is fixed, commands for both a and b should be OK now.

4. Add note specifief in c#6.

Added a new step for this (new step 3)
Comment 9 Jan Martiska 2012-10-11 03:17:28 EDT
Okay it looks fine now, thanks.
Comment 10 Jan Martiska 2012-10-15 07:30:12 EDT
One more thing, please! :D

on Windows open C:\Program Files\jboss-ews-2.0\sbin\tomcat<VERSION>.sh

----> something like

on Windows open %TOMCAT_HOME%\bin\catalina.bat 
(depending on the version of Tomcat you want to set up)
Comment 11 Misha H. Ali 2012-10-16 02:30:03 EDT
Change made, this bug will be set to ON_QA when the results appear.
Comment 13 Radim Hatlapatka 2012-10-22 04:36:37 EDT
I see it corrected in your local documentation, but http://documentation-devel.engineering.redhat.com/docs/en-US/index.html is already for some time up and running and there it is still not corrected => changing back to assigned
Comment 14 Misha H. Ali 2012-10-22 05:54:03 EDT
Setting back to QA. I will send an email to inform you when the recovered stage is updated, after which you can verify.
Comment 15 Jan Martiska 2012-10-22 07:24:36 EDT
okay fixed!
Comment 16 Misha H. Ali 2012-11-08 17:11:16 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.