Bug 86456 - Settings not saving properly
Settings not saving properly
Status: CLOSED DUPLICATE of bug 89948
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-22 10:23 EST by tebucky
Modified: 2007-04-18 12:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tebucky 2003-03-22 10:23:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Let me start by saying that I am a newbie, so please bare with me.  I recently 
installed Redhat 8 and everything went smooth.  I'm using a KVM switch with a 
microsoft ps/2 intellie mouse.  

This is my problem.  When I restart, my mouse settings do not save.  I do 
a "redhat-config-mouse" and select the appropriate mouse, it saves and 
everything works fine.  However, when I reboot the setting does not save and my 
mouse in inoperable.  

Can you assist me in detail on how I can remedy this?  
TIA!!!!!



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Redhat-config-mouse, select the appropriate mouse, save it
2.Reboot
3.Setting do not save
    

Additional info:
Comment 1 Brent Fox 2003-03-24 12:21:32 EST
Do you mean that the settings are messed up in X or on the console?  Or both?
Comment 2 tebucky 2003-03-24 15:05:41 EST
Both I beleive.  It saves the setting temporarily, but when the machine reboots 
it loses the setting somehow.  Making my mouse to behave in a crazy fashion.  
Does that help?
Comment 3 Michael J. Kofler 2003-04-23 08:13:06 EDT
I'm having a similar problem. I upgraded from RH8.x to 9. I use a Data Transfer
Switch to sare mouse/keyboard/monitor bwtween 2 computers. Previously, I could
switch back and forth between the 2 boxes eaasily. Now, when I switch over to
the other box, then back to the RH9, my mouse no longer works. The keyboard and
monitor both switch fine. The mouse has always done so as well until this latest
version. I can use the keyboard to run redhat-config-mouse, which will make the
mouse work again (until the next time i switch back and forth). A
ctrl-alt-backspace restart of X also results in returned mouse functionallity.
I'm using a microsoft optical wheel mouse (ps/2), which i define as "generic
wheel mouse" in setup. 
Thanks,
M
Problem: Mouse stops working when Data Transfer Switch is used to switch b/t 2
machines.
Expected Results: Mouse works normally when switched back, as it has in previous
RH versions.
Comment 4 Brent Fox 2003-05-20 16:24:49 EDT
Ah, ok.  I think that this problem is caused by the interaction between X and
the KVM.  Basically, no KVMs are officially supported because they all seem to
be different in how they pass along the mouse signals.  KVM's are basically the
luck of the draw in if they will work or not.  

I bought one Belkin KVM that works.  Later I bought a second Belkin KVM which
was a new model that replaced my old Belkin...it makes the mouse go crazy in X.
 I'm not sure if there's anything we can do.

I'll transfer this bug to Mike Harris so he can say for sure.
Comment 5 Mike A. Harris 2003-05-20 18:36:51 EDT
Brent's assessment is correct, KVM switches are often very problematic, and
are not supported by Red Hat.  Rationale and further details can be obtained
by following the link below to the KVM master bug report.



*** This bug has been marked as a duplicate of 89948 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:52:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.