Bug 86461 - Mouse stops functioning after selecting a model during setup
Mouse stops functioning after selecting a model during setup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-22 17:30 EST by Mike
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 23:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike 2003-03-22 17:30:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
Serial mouse was working fine during setup, but at the Mouse Configuration 
screen it stopped working after I selected the "Microsoft Rev 2.1A or higher 
(serial)" driver.

Had a similar problem when configuring the mouse model in GNOME on another 
machine.  Mouse stopped working until machine was rebooted.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Connect a serial mouse, Rev 2.1A or higher.
2.  At Mouse Configuration screen, change the default serial mouse to this 
model.
3.  Click Next and mouse stops working.
    

Actual Results:  Mouse stops working, have to reboot to get functionality back.

Expected Results:  Mouse continues to work.

Additional info:
Comment 1 Michael Fulbright 2003-03-24 12:54:10 EST
Is this the Mouse Configuration screen in the installation program, or one you
run after installation and reboot?
Comment 2 Mike 2003-03-24 21:30:11 EST
It's the Mouse Configuration screen in the installation program.
Comment 3 Michael Fulbright 2003-04-02 15:22:17 EST
Matt is this the issue you fixed for Red Hat Linux 9?
Comment 4 Matt Wilson 2003-04-02 15:35:24 EST
usually this is because the mouse gets set in "generic 3 button mouse" or
"Intellimouse" protocol, when the machine is expecting the opposite.  This
should be better in Red Hat Linux 9, but I do not know if it will fix this exact
problem or not.
Comment 5 Jeremy Katz 2004-10-04 23:07:54 EDT
With the completely different input subsystem in the 2.6 kernel, this
shouldn't be an issue any longer.

Note You need to log in before you can comment on or make changes to this bug.