Bug 864611 - When brick directory doesn't exist, volume creation should fail
When brick directory doesn't exist, volume creation should fail
Status: CLOSED DUPLICATE of bug 948729
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Krutika Dhananjay
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 14:16 EDT by Shawn Heisey
Modified: 2014-07-11 11:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-11 11:27:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Heisey 2012-10-09 14:16:00 EDT
Description of problem:
If one or more of the brick directories specified in a "gluster volume" create" command don't exist, the command will create those directories and then proceed to create the volume.  I believe that if any directories are missing, the command should fail.

Steps to Reproduce:
1. Create /bricks/b1 on each server.  Ensure this directory is empty on all servers.
2. Issue a command to create a volume using brick directories that do not exist.
gluster volume create testvol replica 2 transport tcp srv1:/bricks/b1/vol srv2:/bricks/b1/vol
3. Note that the vol directory now exists on all servers and the volume has been 

Expected results:
It should have refused to create the volume, with a helpful error message indicating which directories did not exist.
Comment 1 Amar Tumballi 2012-11-21 04:33:58 EST
http://review.gluster.org/4214
Comment 2 Krutika Dhananjay 2013-07-25 01:00:14 EDT
http://review.gluster.org/#/c/4740/ fixes this issue and is merged in 3.4 branch in upstream. Hence, moving the state of the bug to MODIFIED.
Comment 3 Niels de Vos 2014-07-11 11:27:18 EDT

*** This bug has been marked as a duplicate of bug 948729 ***

Note You need to log in before you can comment on or make changes to this bug.