Bug 864622 - rpm when invoked by yum's tsflags=nodocs fails on installing gawk
rpm when invoked by yum's tsflags=nodocs fails on installing gawk
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 15:03 EDT by Lennart Poettering
Modified: 2012-11-19 06:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 06:57:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2012-10-09 15:03:04 EDT
Tried to install a container with this command:

yum -y \
    --setopt=tsflags=nodoc \
    --setopt=keepcache=0 \
    --installroot=/home/lennart/minimal/install \                     
    --nogpg \
    --releasever=18 \
    '--disablerepo=*' \
    --enablerepo=fedora \
    install systemd passwd openssh-server rpm

But this failed to install due to gawk:

...
  Installing : shared-mime-info-1.0-5.fc18.x86_64                                                                             51/106 
  Installing : grep-2.14-1.fc18.x86_64                                                                                        52/106 
install-info: No such file or directory for /usr/share/info/grep.info.gz
  Installing : gawk-4.0.1-2.fc18.x86_64                                                                                       53/106 
Error unpacking rpm package gawk-4.0.1-2.fc18.x86_64
error: unpacking of archive failed on file /usr/share/man/man1/gawk.1.gz;507472b1: cpio: Missing hard link(s)
  Installing : libidn-1.25-3.fc18.x86_64                                                                                      54/106 
error: gawk-4.0.1-2.fc18.x86_64: install failed
install-info: No such file or directory for /usr/share/info/libidn.info.gz
  Installing : 1:gmp-5.0.5-3.fc18.x86_64                                                                                      55/106 
  Installing : ncurses-5.9-5.20120204.fc18.x86_64  
...
Comment 1 Fedora Update System 2012-10-10 04:13:02 EDT
rpm-4.10.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rpm-4.10.1-2.fc18
Comment 2 Fedora Update System 2012-10-10 14:08:17 EDT
Package rpm-4.10.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpm-4.10.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15818/rpm-4.10.1-2.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-10-12 13:57:04 EDT
Package rpm-4.10.1-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpm-4.10.1-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15818/rpm-4.10.1-3.fc18
then log in and leave karma (feedback).
Comment 4 Panu Matilainen 2012-11-19 06:57:14 EST
Bodhi appears to have lost track of this bug, it was moved to stable nearly a month ago -> closing manually.

Note You need to log in before you can comment on or make changes to this bug.