Bug 864651 - Include contrib/subtree for git-subtree command
Include contrib/subtree for git-subtree command
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 16:56 EDT by Ali Salim Rashid
Modified: 2013-04-30 19:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 00:22:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali Salim Rashid 2012-10-09 16:56:39 EDT
Description of problem: 
The popular 'git subtree' command (https://github.com/apenwarr/git-subtree), commonly used as an alternative to 'git submodule' has been merged into contrib/subtree of the mainline git repository and is available as of git-1.7.11, with maintenance no longer continuing on the original project. 

It would be great if Fedora's git was built with contrib/subtree, so users of 'git subtree' don't have to build git from source.

Version-Release number of selected component (if applicable):
>= 1.7.11

How reproducible:
Always

Steps to Reproduce:
1. git clone https://github.com/gitster/git.git
2. cd git
3. git subtree add -P ourSubtree https://github.com/gitster/git.git
  
Actual results:
git: 'subtree' is not a git command. See 'git --help'.

Expected results:
Subtree containing https://github.com/gitster/git.git repository should be created in 'ourSubtree' subdirectory (prefix)

Additional info:
https://github.com/apenwarr/git-subtree/blob/master/git-subtree.txt
https://github.com/apenwarr/git-subtree/blob/master/THIS-REPO-IS-OBSOLETE
http://news.ycombinator.com/item?id=3926683
Comment 1 Tetra 2012-11-28 14:43:27 EST
Alternative :

git clone https://github.com/git/git.git

cd contrib/subtree

sudo make prefix=/usr
sudo make prefix=/usr install
sudo make prefix=/usr install-doc

Then command git subtree should be available.
Comment 2 Todd Zullinger 2012-11-29 10:22:26 EST
Nice, thanks Tetra.  This might be a good candidate for a new subpackage?  That way we're not installing it by default and making folks think that it's an officially supported part of git.
Comment 3 Adam Tkac 2012-11-29 10:31:36 EST
(In reply to comment #2)
> Nice, thanks Tetra.  This might be a good candidate for a new subpackage? 
> That way we're not installing it by default and making folks think that it's
> an officially supported part of git.

I think we can just install it as other officially supported git-* stuff, i.e. into /usr/libexec/git-core/, can't we? What's benefit of the separate package?

If something happens to git-subtree and we remove it from the git package, it will be same impact for it's users as with git-subtree package. And the rest of users who doesn't use git-subtree at all won't notice anything.
Comment 4 Todd Zullinger 2012-11-29 10:47:23 EST
It's certainly a valid concern as to what would happen if/when subtree becomes an official part of git.  From packaging, I would think that we'd just add a provides/obsoletes to git at that time.

My main concern was causing confusion as to whether it was officially supported.  If someone installs git from our packages and then takes bug reports or complaints to the git list, will our packaging it as part of git cause trouble for upstream or us?  I may well be worried about nothing. :)

(We do include the completion script, which is currently in contrib, so there's one counter example.)
Comment 5 Adam Tkac 2012-11-29 11:22:49 EST
(In reply to comment #4)
> It's certainly a valid concern as to what would happen if/when subtree
> becomes an official part of git.  From packaging, I would think that we'd
> just add a provides/obsoletes to git at that time.
> 
> My main concern was causing confusion as to whether it was officially
> supported.  If someone installs git from our packages and then takes bug
> reports or complaints to the git list, will our packaging it as part of git
> cause trouble for upstream or us?  I may well be worried about nothing. :)

Since git-subtree is in the upstream git repository (although in contrib/), I think it is officially supported. We can forward bugs against it to upstream and we can also send them patches. So in my opinion we can safely include it in the main git pkg.
Comment 6 Fedora Update System 2012-11-29 11:55:19 EST
git-1.8.0.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/git-1.8.0.1-1.fc18
Comment 7 Fedora Update System 2012-11-30 01:43:48 EST
Package git-1.8.0.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing git-1.8.0.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19412/git-1.8.0.1-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-12-04 00:22:52 EST
git-1.8.0.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.