Bug 864653 - Need a REST API to request the log directory of a cartridge
Need a REST API to request the log directory of a cartridge
Status: CLOSED UPSTREAM
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
: 876721 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 16:57 EDT by chris alfonso
Modified: 2016-01-31 21:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-29 13:58:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris alfonso 2012-10-09 16:57:29 EDT
Description of problem:
Need a REST API to request the log directory of a cartridge.  Currently, we have to make an assumption on the location of the log directory.  Ideally, we would be able to look this up on a cartridge property.

Although there maybe be a property that contains the log directory of a cartridge, there is no way to know the property is the log directory.  For instance, the node-js cartridge has properties":[{"name":"OPENSHIFT_NODEJS_LOG_DIR","description":"Directory to store application log files.","type":"environment"}]  But we can't count on the existence of _LOG_ in the name to properly identify the environment variable.
Comment 1 Dan McPherson 2012-10-09 17:59:25 EDT
This should probably be a story.
Comment 2 Clayton Coleman 2012-10-15 10:48:46 EDT
The other option is for there to be a script on the node via SSH that aggregates the logs, and for the CLI to invoke that and stream its output.  Then users could tweak it on their gears.
Comment 3 Dan McPherson 2013-01-28 19:04:17 EST
*** Bug 876721 has been marked as a duplicate of this bug. ***
Comment 4 Dan McPherson 2013-01-29 13:58:50 EST
Created US3373 to track.

Note You need to log in before you can comment on or make changes to this bug.