Bug 86466 - anaconda fails to initialize during install
anaconda fails to initialize during install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-23 01:11 EST by Michael Soulier
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-07 14:54:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Soulier 2003-03-23 01:11:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
This was attempted with RedHat 7.3 and 8.0, both with the same results. I
attempted to install both versions of RedHat on my wife's PC, running a P-III
800. In both cases, anaconda fails with an error regarding a failure to allocate
memory. 

I would point out that her box is currently running Debian Linux, so she does
not appear to have a hardware problem. I would suggest that the problem is
either anaconda, or the bootloader used to load anaconda. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot off RedHat 7.3 or 8.0 CD.
2. Press 'Enter' at the prompt, or enter "linux text".
3. Watch anaconda fail.
    

Actual Results:  Anaconda fails with an error regarding an inability to allocate
memory. I would capture it for you, but it fails so early in the process that I
have to go on memory. 

Expected Results:  I expected to be able to use anaconda to install RedHat Linux.

Additional info:

As the machine in question is currently running Debian Linux, I'll glean some
information for you. 

msoulier@poohbear:~$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 801.822
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 mmx fxsr sse
bogomips        : 1599.07

msoulier@poohbear:~$ lspci
00:00.0 Host bridge: ALi Corporation M1621 (rev 04)
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller (rev 01)
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV] (rev c3)
00:0c.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
00:0c.1 Communication controller: C-Media Electronics Inc CM8738 (rev 10)
00:0e.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100
Ethernet (rev 02)
00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c2)
01:00.0 VGA compatible controller: nVidia Corporation NV5 [Aladdin TNT2] (rev 20)

Please let me know if you need anything else.
Comment 1 Michael Fulbright 2003-03-24 12:53:18 EST
How much RAM and swap does the system have configured?
Comment 2 Michael Soulier 2003-03-24 13:17:41 EST
msoulier@poohbear:~$ free
             total       used       free     shared    buffers     cached
Mem:        159516     155056       4460          0      35080      44520
-/+ buffers/cache:      75456      84060
Swap:       489908      57116     432792

Mind you, this was a brand-new install, so the swap isn't important here, is it?

Comment 3 Michael Fulbright 2003-04-02 15:27:42 EST
If you have less than 192MB of RAM its important even when doing a fresh install
that RAM+swap >= 256MB.

Was that the case with your install attempts?
Comment 4 Michael Soulier 2003-04-02 17:02:18 EST
> If you have less than 192MB of RAM its important even when doing a fresh install
> that RAM+swap >= 256MB.

I'm intrigued to know why swap is important for the installer, when no
assumptions about the platform can be made, since the disk could be brand new
and not even partitioned yet. Are you saying the anaconda will use the native
swap, and then stop using it for disk druid, and then start using it again?

> Was that the case with your install attempts?

No. Above you will see that the system had 192M of RAM, and 500M of swap. It was
a Debian install at the time we rebooted it and tried to install both RedHat 7.3
and 8.0. We got the error in both cases.
Comment 5 Michael Fulbright 2003-04-04 16:25:19 EST
No if its happening before you get to the option of partitioning then we have
not turned any swap on yet. However 192M of RAM should be adequate.

Does it fail before the 'Running anaconda....' message is printed out?
Comment 6 Michael Soulier 2003-04-04 18:55:21 EST
> Does it fail before the 'Running anaconda....' message is printed out?

Upon booting the CD, the kernel boots, /sbin/loader runs, and the blue screen
with "Welcome to RedHat Linux" comes up. 

It then sits there, apparently doing nothing, for several (read: 20+) minutes.
There is some harddrive activity.

Aha. The third virtual terminal shows "modules to insert ide-cd"

The fourth terminal shows endless looping on the part of the ide controller for
the CD. 

"<4>Error -3 while decompressing!"
"<4>hdc: irq timeout: status=0xd0 { Busy }"
"<4>ATAPI reset complete"
"<4>hdc: cdrom_decode_status: status=0x51 { DriveReady SeekComplete Error }"

These are the same CDs that I used to install my current RedHat 8.0 system, and
I've used the 7.3 CDs before too. They're from the same burner that made the
Debian CDs that we installed on that box. Odd.
Comment 7 Michael Fulbright 2003-04-07 14:54:26 EDT
You certainly have a case of CD media and your CD drive not liking each other.

CDs can be frustrating let me tell you...

I'd try a different CD drive to see if that helps.

Note You need to log in before you can comment on or make changes to this bug.