Bug 864672 - RFE: user-friendly time-period restriction for the journalctl command line
RFE: user-friendly time-period restriction for the journalctl command line
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 18:03 EDT by Matthew Miller
Modified: 2012-12-20 10:23 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:23:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-10-09 18:03:06 EDT
A common sysadmin task is looking in the logs to see what occurred in a given time window.

It would be nice if journalctl had a flexible, forgiving, and user-friendly command line syntax for specifying begin and end dates to show.
Comment 1 Lennart Poettering 2012-10-12 17:49:02 EDT
Fixed in git:

journalctl --since=2012-10-01

journalctl --since=-5d --until=-6h

journalctl --since=yesterday

and so on.

Since this is a minor change only I'll upload this to F18.
Comment 2 Matthew Miller 2012-10-15 08:46:17 EDT
Thanks Lennart. This is very useful and helpful.

It occurs to me that it might be nice to have an "--ondate=2012-10-01" or similar as well, to avoid having to give both start and end. But I understand there's a balance with adding more options.
Comment 3 Fedora Update System 2012-10-22 21:04:16 EDT
systemd-195-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/systemd-195-1.fc18
Comment 4 Fedora Update System 2012-10-23 02:47:48 EDT
Package systemd-195-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-195-1.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16709/systemd-195-1.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-10-26 15:37:10 EDT
Package systemd-195-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-195-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16709/systemd-195-2.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-20 10:23:17 EST
systemd-195-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.