Bug 864674 - RFE: add tab completion for match expressions in journalctl
RFE: add tab completion for match expressions in journalctl
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 18:10 EDT by Matthew Miller
Modified: 2012-12-20 10:23 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:23:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-10-09 18:10:27 EDT
This is a small user-interface request.

Right now, the filtering syntax for journalctl uses literal fields from systemd.journal-fields.

The filtering is handy, but it would be nice if the field names could also be lower case. Needing to switch to all-caps to type long field names is not as user friendly as it could be.

Tab completion would be awesome too.
Comment 1 Lennart Poettering 2012-10-15 10:24:23 EDT
Hmm, so I think I am pretty much against transparently transposing these fields from lower-case to upper-case, as things on Unix are generally not done that way. i.e. file names are case-sensitive, env vars are, udev vars are, and so on and so on. I think it would be quite surprising if we added such an automatism to journalctl but nothing else.

If people can be bothered to care about case sensitivity for env vars I think it's not too much to ask to care about it for journal matches, too.

That said, tab completion definitely is a good thing. I'll take the liberty to relabel this bug report to ask for tab compeltion for journal matches.
Comment 2 Matthew Miller 2012-10-15 10:56:29 EDT
I can buy that rationale. Change to the RFE works for me.
Comment 3 Lennart Poettering 2012-10-18 20:49:07 EDT
Tab completin for journalctl matches is now implemented. Soon in F18
Comment 4 Fedora Update System 2012-10-22 21:04:25 EDT
systemd-195-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/systemd-195-1.fc18
Comment 5 Fedora Update System 2012-10-23 02:48:00 EDT
Package systemd-195-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-195-1.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16709/systemd-195-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-10-26 15:37:18 EDT
Package systemd-195-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-195-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16709/systemd-195-2.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-12-20 10:23:29 EST
systemd-195-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.