Bug 86471 - openssl-devel depends on kerberos headers not in standard include path
Summary: openssl-devel depends on kerberos headers not in standard include path
Status: CLOSED DUPLICATE of bug 82369
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssl   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-23 11:02 UTC by Henrik Nordstrom
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henrik Nordstrom 2003-03-23 11:02:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.1 i586)

Description of problem:
In file included from /usr/include/openssl/ssl.h:179,
/usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory


The kerberos headers can be found in
/usr/kerberos/include/krb5.h


Version-Release number of selected component (if applicable):
openssl-devel-0.9.7-6

How reproducible:
Always

Steps to Reproduce:
1.Try to compile a C program using OpenSSL, such as this silly dummy program

#include <openssl/ssl.h>
int main(int argc, char **argv) {]


Actual Results:  In file included from /usr/include/openssl/ssl.h:179,
/usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory


Expected Results:  No error.

Additional info:

Compilation works if /usr/kerberos/include is added to the include path, but
this does not seem right to me.

Comment 1 Joe Orton 2003-03-25 23:27:30 UTC

*** This bug has been marked as a duplicate of 82369 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:17 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.