Bug 864792 - Typo in %post scriptlet of qpid-cpp-server makes it fail
Typo in %post scriptlet of qpid-cpp-server makes it fail
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qpid-cpp (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 03:14 EDT by Jan van Eldik
Modified: 2015-06-21 20:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 15:36:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan van Eldik 2012-10-10 03:14:28 EDT
Description of problem:

RPM upgrade fails because of typo in %post scriptlet of qpid-cpp-server.

There seems to be a missing blank in

  if [$1 -eq 1] ; then
      # Initial installation
      /sbin/systemctl --no-reload enable qpidd.service >/dev/null 2>&1 || :
  fi

Which leads to

  D: %post(qpid-cpp-server-0.18-2.fc17.x86_64): execv(/bin/sh) pid 4088
  + '[2' -eq '1]'
  /var/tmp/rpm-tmp.IaBxlF: line 2: [2: command not found

Changing the first line to "if [ $1 -eq 1] ; then" should fix this.


Version-Release number of selected component (if applicable):

qpid-cpp-client-0.18-2.fc17

How reproducible:

100%
Comment 1 Fedora Update System 2012-10-10 07:39:42 EDT
qpid-cpp-0.18-3.1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-3.1.fc17
Comment 2 Jan van Eldik 2012-10-10 07:45:37 EDT
Works for me, Karma given.

  thanks, Jan
Comment 3 Fedora Update System 2012-10-10 08:07:14 EDT
qpid-cpp-0.18-3.1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-3.1.fc18
Comment 4 Jan van Eldik 2012-10-10 09:45:58 EDT
Hi,

Seems another bug was lurking there - the scriptlet should use
"/bin/systemctl" rather than "/sbin/systemctl".

Let me know if you prefer a separate BZ for this.

  cheers, Jan
Comment 5 Darryl L. Pierce 2012-10-10 09:49:52 EDT
(In reply to comment #4)
> Hi,
> 
> Seems another bug was lurking there - the scriptlet should use
> "/bin/systemctl" rather than "/sbin/systemctl".
> 
> Let me know if you prefer a separate BZ for this.
> 
>   cheers, Jan

Yeah, that way we can track it separately.
Comment 6 Jan van Eldik 2012-10-10 11:06:23 EDT
OK, just opened 864987

cheers, Jan
Comment 7 Fedora Update System 2012-10-10 14:05:59 EDT
Package qpid-cpp-0.18-3.1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qpid-cpp-0.18-3.1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15794/qpid-cpp-0.18-3.1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-10-12 20:56:33 EDT
qpid-cpp-0.18-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-4.fc17
Comment 9 Fedora Update System 2012-10-13 22:42:27 EDT
qpid-cpp-0.18-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-4.fc18
Comment 10 Fedora Update System 2012-10-16 11:31:03 EDT
qpid-cpp-0.18-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-5.fc17
Comment 11 Fedora Update System 2012-10-16 13:14:54 EDT
qpid-cpp-0.18-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-5.fc18

Note You need to log in before you can comment on or make changes to this bug.