Bug 864806 - Missing Tabs when clicked on grant access button of the deployable page.
Missing Tabs when clicked on grant access button of the deployable page.
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta5
: ---
Assigned To: Shveta
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 03:34 EDT by Aziza Karol
Modified: 2012-12-04 10:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Tabs were missing after clicking the grant access button on the Application Blueprints page. This patch removes the empty admin_nav div if no administer navigation is rendered. A future release of CloudForms will merge the Monitor and Administer sections together, which eradicates this issue.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:08:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
all tabs missing (44.18 KB, image/png)
2012-10-10 03:35 EDT, Aziza Karol
no flags Details
empty panel hidden (53.06 KB, image/png)
2012-10-17 18:14 EDT, Shveta
no flags Details

  None (edit)
Description Aziza Karol 2012-10-10 03:34:35 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create a deployable and click on the deployable name.
2.click on grant access button in the Role Assignments section.
  
Actual results:
Tabs missing. see attached screnshot.

Expected results:
Tabs should be present.

Additional info:
 rpm -qa | grep aeolus
aeolus-conductor-doc-0.13.17-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
aeolus-all-0.13.17-1.el6cf.noarch
aeolus-conductor-0.13.17-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-conductor-daemons-0.13.17-1.el6cf.noarch
Comment 1 Aziza Karol 2012-10-10 03:35:11 EDT
Created attachment 624643 [details]
all tabs missing
Comment 3 Steve Linabery 2012-10-15 13:58:05 EDT
https://github.com/aeolusproject/conductor/pull/124
Comment 4 Scott Seago 2012-10-15 17:47:50 EDT
So we didn't actually restore the tabs. The long-term solution would be to either use an ajax call to only refresh the content panel, or use an overlay/popup. The idea is that the 'add permissions' form is reused in various places on the site, and it needs to appear in the context of the page in which it's being used. For global permissions, the nav works properly now -- showing the right spot under Administer->Users->Global Role Grants. For the other places (pool permissions, etc) we're just hiding the empty tab container, as the ajax solution seems to be too invasive a change for a 1.1 blocker. In any case, when you're on the 'add permissions' page, you get back to where you were by either submitting something and hitting 'grant access', or by hitting 'cancel'.

Change is on master at 7497b83ac4b383b06ed5b245e3e85d6f8e1ccc95.
Comment 6 Shveta 2012-10-17 18:14:54 EDT
Created attachment 629110 [details]
empty panel hidden

Empty panel is not shown now.
rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.20-1.el6cf.noarch
rubygem-aeolus-cli-0.7.5-1.el6cf.noarch
aeolus-conductor-doc-0.13.20-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-all-0.13.20-1.el6cf.noarch
aeolus-conductor-0.13.20-1.el6cf.noarch
Comment 8 errata-xmlrpc 2012-12-04 10:08:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.