Bug 864842 - AttributeError: 'NoneType' object has no attribute 'id'
Summary: AttributeError: 'NoneType' object has no attribute 'id'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ee6e2827438ae20146aecd339e4...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-10 08:57 UTC by Kamil Páral
Modified: 2012-11-26 14:13 UTC (History)
6 users (show)

Fixed In Version: anaconda-18.15-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-23 04:37:32 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (614.90 KB, text/plain)
2012-10-10 08:57 UTC, Kamil Páral
no flags Details
File: environ (885 bytes, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: type (9 bytes, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: storage.log (260.86 KB, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: version (2 bytes, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: program.log (148.75 KB, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: product (6 bytes, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: anaconda.log (5.81 KB, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: cmdline_file (204 bytes, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: release (33 bytes, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
File: messages (161.79 KB, text/plain)
2012-10-10 08:58 UTC, Kamil Páral
no flags Details
screenshot (54.60 KB, image/png)
2012-10-11 17:03 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2012-10-10 08:57:53 UTC
Description of problem:
In the partitioning dialog I clicked on "summary" (or similar), selected my disk and hit Remove. I assumed that would erase the whole disk.

Version-Release number of selected component:
anaconda-18.14-1.fc18.x86_64

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.14 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 136, in on_remove_clicked
:    if disk.id == self._store[itr][ID_COL]:
:AttributeError: 'NoneType' object has no attribute 'id'

Comment 1 Kamil Páral 2012-10-10 08:57:58 UTC
Created attachment 624665 [details]
File: anaconda-tb

Comment 2 Kamil Páral 2012-10-10 08:58:05 UTC
Created attachment 624666 [details]
File: environ

Comment 3 Kamil Páral 2012-10-10 08:58:07 UTC
Created attachment 624667 [details]
File: type

Comment 4 Kamil Páral 2012-10-10 08:58:10 UTC
Created attachment 624668 [details]
File: ifcfg.log

Comment 5 Kamil Páral 2012-10-10 08:58:13 UTC
Created attachment 624669 [details]
File: storage.log

Comment 6 Kamil Páral 2012-10-10 08:58:15 UTC
Created attachment 624670 [details]
File: version

Comment 7 Kamil Páral 2012-10-10 08:58:18 UTC
Created attachment 624671 [details]
File: program.log

Comment 8 Kamil Páral 2012-10-10 08:58:20 UTC
Created attachment 624672 [details]
File: product

Comment 9 Kamil Páral 2012-10-10 08:58:22 UTC
Created attachment 624673 [details]
File: anaconda.log

Comment 10 Kamil Páral 2012-10-10 08:58:24 UTC
Created attachment 624674 [details]
File: hashmarkername

Comment 11 Kamil Páral 2012-10-10 08:58:26 UTC
Created attachment 624675 [details]
File: cmdline_file

Comment 12 Kamil Páral 2012-10-10 08:58:28 UTC
Created attachment 624676 [details]
File: release

Comment 13 Kamil Páral 2012-10-10 08:58:31 UTC
Created attachment 624677 [details]
File: messages

Comment 14 Kamil Páral 2012-10-10 09:00:07 UTC
Always reproducible. Proposing as Beta blocker.

Comment 15 Chris Lumens 2012-10-10 13:16:59 UTC
No, it won't erase the whole disk.  It just removes it from consideration as an installation source, same as if you unclicked it on the storage overview screen.  Still shouldn't crash.

Comment 16 Kamil Páral 2012-10-10 14:14:39 UTC
(In reply to comment #15)
> No, it won't erase the whole disk.  It just removes it from consideration as
> an installation source, same as if you unclicked it on the storage overview
> screen.

That's not clear at all. Of course that's a different issue, let's fix crashes first.

Comment 17 Chris Lumens 2012-10-10 15:14:54 UTC
I wouldn't say it's not clear.  The wording is "Remove", not "Erase" or "Delete Filesystems" or anything like that.  Also when you click it, you can later see the effects on the storage overview.

Comment 18 Fedora Update System 2012-10-11 01:05:13 UTC
anaconda-18.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.15-1.fc18

Comment 19 Fedora Update System 2012-10-11 02:58:47 UTC
Package anaconda-18.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.15-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15903/anaconda-18.15-1.fc18
then log in and leave karma (feedback).

Comment 20 Kamil Páral 2012-10-11 17:03:59 UTC
Created attachment 625591 [details]
screenshot

Comment 21 Adam Williamson 2012-10-11 17:21:13 UTC
Discussed at 2012-10-11 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-11/f18beta-blocker-review-3.1.2012-10-11-16.04.log.txt . Agreed that this is not a Beta blocker, it doesn't really hit any criteria, the operation you have to do to hit it is not a valid one (so it's not stopping you doing anything you'd actually want to do), and it's easy to recover, just reboot and start over (you're likely to hit this early in your install attempt so you won't have lost a lot of work).

Comment 22 Fedora Update System 2012-10-12 01:07:00 UTC
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18

Comment 23 Fedora Update System 2012-10-17 03:10:07 UTC
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18

Comment 24 Fedora Update System 2012-10-18 02:38:51 UTC
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18

Comment 25 Fedora Update System 2012-10-20 01:34:42 UTC
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18

Comment 26 Adam Williamson 2012-11-23 04:37:32 UTC
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Comment 27 Kamil Páral 2012-11-23 10:00:37 UTC
Confirmed fixed in anaconda 18.29.2.

Comment 28 Kamil Páral 2012-11-26 14:13:32 UTC
Removing CommonBugs because this has been fixed before F18 Beta release.


Note You need to log in before you can comment on or make changes to this bug.