Bug 86486 - RPM database corruption in failed (single) package update
RPM database corruption in failed (single) package update
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-23 22:49 EST by keithu@parl.clemson.edu
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-28 14:45:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description keithu@parl.clemson.edu 2003-03-23 22:49:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
I ran an rpm -i for kernel-2.4.18-27.7.x and it hung (for a LONG time).  I did
Ctrl-C and tried again.  Same result.  Now, I have two entries for it in the RPM
database (and so can't remove it - rpm complains that the name specifies
multiple packages).  Now what?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fail an RPM install
2.try again
3.try to remove the RPM 
    

Additional info:
Comment 1 Jeff Johnson 2003-03-28 14:45:35 EST
Do
   rpm -evv --allmatches kernel-X-Y
where X == the version, and Y == the release, you want to remove.

If still hanging, do
    rm -f /var/lib/rpm/__db*
first.
Comment 2 keithu@parl.clemson.edu 2003-03-28 15:22:10 EST
Thanks.  Worked great.  BTW, do you just put the vv in there as vengence against
those who fail to RTFM? ;-)

Note You need to log in before you can comment on or make changes to this bug.