Bug 864880 - libuser: file locking incompatible with shadow-utils
libuser: file locking incompatible with shadow-utils
Status: CLOSED DUPLICATE of bug 1246225
Product: Fedora
Classification: Fedora
Component: libuser (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 864888
  Show dependency treegraph
 
Reported: 2012-10-10 06:35 EDT by Florian Weimer
Modified: 2015-07-23 14:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-23 14:13:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2012-10-10 06:35:37 EDT
libuser uses fnctl locking for files in /etc, but shadow-utils uses .lock files.  Therefore, the two approaches do not achieve mutual exclusion.

This is based on shadow-utils 2:4.1.5.1-1 and libuser 0.57.7-1.
Comment 1 Miloslav Trmač 2012-10-24 22:17:58 EDT
Thanks for your report.

(Fixing this should also allow us to better fix #454646 and #454443.)
Comment 2 Fedora End Of Life 2013-04-03 15:33:45 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 3 Florian Weimer 2013-12-19 11:24:57 EST
Still present in libuser-0.60.
Comment 4 Tomas Mraz 2014-09-30 10:14:57 EDT
*** Bug 1148008 has been marked as a duplicate of this bug. ***
Comment 5 Jan Kurik 2015-07-15 10:58:22 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23
Comment 6 Florian Weimer 2015-07-23 14:13:51 EDT

*** This bug has been marked as a duplicate of bug 1246225 ***

Note You need to log in before you can comment on or make changes to this bug.