Bug 864918 - [Backend] NPE when starting stateless VM (at org.ovirt.engine.core.bll.Backend.endAction(Backend.java:355))
[Backend] NPE when starting stateless VM (at org.ovirt.engine.core.bll.Backen...
Status: CLOSED DUPLICATE of bug 863766
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Michal Skrivanek
Jakub Libosvar
virt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 07:50 EDT by Jakub Libosvar
Modified: 2012-10-18 03:47 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 03:47:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (39.62 KB, application/octet-stream)
2012-10-10 07:50 EDT, Jakub Libosvar
no flags Details

  None (edit)
Description Jakub Libosvar 2012-10-10 07:50:01 EDT
Created attachment 624809 [details]
engine log

Description of problem:
When starting VM with stateless=True, NPE occurs:
2012-10-10 13:11:43,690 ERROR [org.ovirt.engine.core.bll.EntityAsyncTask] (pool-4-thread-50) EntityAsyncTask::EndCommandAction [within thread]: EndAction for action type RunVmOnce threw an exception: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.Backend.endAction(Backend.java:355) [engine-bll.jar:]
	at sun.reflect.GeneratedMethodAccessor207.invoke(Unknown Source) [:1.7.0_05-icedtea]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_05-icedtea]
	at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_05-icedtea]
	at org.jboss.as.ee.component.ManagedReferenceMethodInterceptorFactory$ManagedReferenceMethodInterceptor.processInvocation(ManagedReferenceMethodInterceptorFactory.java:72) [jboss-as-ee.jar:7.1.2.Final-redhat-1]
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.jboss.invocation.InterceptorContext$Invocation.proceed(InterceptorContext.java:374) [jboss-invocation.jar:1.1.1.Final-redhat-1]
	at org.ovirt.engine.core.utils.ThreadLocalSessionCleanerInterceptor.injectWebContextToThreadLocal(ThreadLocalSessionCleanerInterceptor.java:11) [engine-utils.jar:]
	at sun.reflect.GeneratedMethodAccessor11.invoke(Unknown Source) [:1.7.0_05-icedtea]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_05-icedtea]
	at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_05-icedtea]
	at org.jboss.as.ee.component.ManagedReferenceLifecycleMethodInterceptorFactory$ManagedReferenceLifecycleMethodInterceptor.processInvocation(ManagedReferenceLifecycleMethodInterceptorFactory.java:123) [jboss-as-ee.jar:7.1.2.Final-redhat-1]


Version-Release number of selected component (if applicable):
rhevm-backend-3.1.0-20.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Have a VM 
2. Start it with stateless checkbox checked (or set it stateless as default)
  
Actual results:
NPE, task hangs

Expected results:
Snapshot is created and VM is started

Additional info:
seems like we already had it - bug 520818
Backend log attached
Comment 3 Frantisek Kobzik 2012-10-18 03:47:52 EDT

*** This bug has been marked as a duplicate of bug 863766 ***

Note You need to log in before you can comment on or make changes to this bug.