Bug 864926 - Change of partition layout leads to GUI freeze
Change of partition layout leads to GUI freeze
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 08:10 EDT by Ladislav Jozsa
Modified: 2013-03-12 10:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 23:37:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (8.68 KB, text/plain)
2012-10-10 08:10 EDT, Ladislav Jozsa
no flags Details
storage.log (65.17 KB, text/plain)
2012-10-10 08:11 EDT, Ladislav Jozsa
no flags Details
X.log (53.26 KB, text/plain)
2012-10-10 08:11 EDT, Ladislav Jozsa
no flags Details
anaconda.log (9.55 KB, text/plain)
2012-10-10 08:38 EDT, Ladislav Jozsa
no flags Details
X.log (53.26 KB, text/plain)
2012-10-10 08:39 EDT, Ladislav Jozsa
no flags Details
storage.log (68.61 KB, text/plain)
2012-10-10 08:39 EDT, Ladislav Jozsa
no flags Details
syslog (63.94 KB, text/plain)
2012-10-10 08:40 EDT, Ladislav Jozsa
no flags Details
program.log (25.09 KB, text/plain)
2012-10-10 08:40 EDT, Ladislav Jozsa
no flags Details
packaging.log (2.38 KB, text/plain)
2012-10-10 08:42 EDT, Ladislav Jozsa
no flags Details
ifcfg.log (641 bytes, text/plain)
2012-10-10 08:42 EDT, Ladislav Jozsa
no flags Details

  None (edit)
Description Ladislav Jozsa 2012-10-10 08:10:35 EDT
Created attachment 624824 [details]
anaconda.log

Description of problem:
By selecting manual partitioning on a system which contains previous installation, repartitioning it according to my needs, then returning to Installation summary and trying to repeat the process leads to frozen GUI after removing old partitions and trying to add new.


Version-Release number of selected component (if applicable):
anaconda 18.14

How reproducible:
always

Steps to Reproduce:
1. Start a new installation on a system that contains previous installation of Linux
2. Choose custom partitioning, remove all old partitions, add some new ( I actually added one big / partition), finish partitioning
3. Repeat step 2
  
Actual results:
The GUI freezes

Expected results:
The GUI should not freeze

Additional info:
Tested on F18 Beta TC3
Comment 1 Ladislav Jozsa 2012-10-10 08:11:02 EDT
Created attachment 624825 [details]
storage.log
Comment 2 Ladislav Jozsa 2012-10-10 08:11:28 EDT
Created attachment 624826 [details]
X.log
Comment 3 Ladislav Jozsa 2012-10-10 08:38:39 EDT
Created attachment 624843 [details]
anaconda.log
Comment 4 Ladislav Jozsa 2012-10-10 08:39:12 EDT
Created attachment 624844 [details]
X.log
Comment 5 Ladislav Jozsa 2012-10-10 08:39:46 EDT
Created attachment 624845 [details]
storage.log
Comment 6 Ladislav Jozsa 2012-10-10 08:40:20 EDT
Created attachment 624846 [details]
syslog
Comment 7 Ladislav Jozsa 2012-10-10 08:40:49 EDT
Created attachment 624847 [details]
program.log
Comment 8 Ladislav Jozsa 2012-10-10 08:42:04 EDT
Created attachment 624848 [details]
packaging.log
Comment 9 Ladislav Jozsa 2012-10-10 08:42:40 EDT
Created attachment 624849 [details]
ifcfg.log
Comment 10 Chris Lumens 2012-10-16 10:53:01 EDT
We've got a set of threading-related patches going into the next build.  Please test again with a tree containing anaconda-18.17-1 and let us know if it works better for you.  Thanks.
Comment 11 Ladislav Jozsa 2012-10-22 06:58:53 EDT
Verified in anaconda 18.19. This particular issue seems to be fixed now.
Comment 12 Adam Williamson 2012-11-22 23:37:45 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(ref comment #11)

Note You need to log in before you can comment on or make changes to this bug.