Bug 864950 - Configure winbind_krb5_locator.so via alternatives to allow IPA AD trusts use - samba package
Configure winbind_krb5_locator.so via alternatives to allow IPA AD trusts use...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Andreas Schneider
qe-baseos-daemons
:
Depends On: 864889
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 09:18 EDT by Alexander Bokovoy
Modified: 2013-02-21 03:45 EST (History)
6 users (show)

See Also:
Fixed In Version: samba-3.6.9-151.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 864889
Environment:
Last Closed: 2013-02-21 03:45:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to introduce alternatives for winbind_krb5_locator.so (3.49 KB, patch)
2012-10-10 09:20 EDT, Alexander Bokovoy
no flags Details | Diff

  None (edit)
Description Alexander Bokovoy 2012-10-10 09:18:19 EDT
+++ This bug was initially created as a clone of Bug #864889 +++

Description of problem:
On IPA server when AD trusts feature is enabled, winbind_krb5_locator.so plugin should not be available to libkrb5. This could be achieved by requiring that samba{,4}-winbind-krb5-locator package is never installed when ipa-server-trust-ad package is installed but much easier to automatically configure through alternatives.

Without this fix winbind_krb5_locator.so plugin to libkrb5 will interfere with winbindd configuration for IPA AD trusts, rendering them unusable.

--- Additional comment from pm-rhel@redhat.com on 2012-10-10 13:51:35 EEST ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from abokovoy@redhat.com on 2012-10-10 13:54:22 EEST ---

Created attachment 624780 [details]
patch to introduce alternatives for winbind_krb5_locator.so

This is spec change that is needed to allow disabling winbind_krb5_locator.so plugin when trusts are in use on the server. Since libkrb5 reads any file in its plugins directory, keeping disabled plugin there is not an option, so I moved it back to %_libdir and used alternatives instead.

When trusts package (ipa-server-trust-ad) is installed, it will alternate to /dev/null for this plugin (link in plugins dir will point to /etc/alternatives/winbind_krb5_locator.so which will point to /dev/null). This will make libkrb5 to effectively ignore the plugin.

When trusts package is uninstalled, samba4 package will automatically be selected as a provider for the winbind_krb5_locator.so and will redirect the link to %_libdir/winbind_krb5_locator.so which is happily used by libkrb5
Comment 1 Alexander Bokovoy 2012-10-10 09:20:09 EDT
Created attachment 624869 [details]
patch to introduce alternatives for winbind_krb5_locator.so

Adopt patch from samba4 to samba package.
Comment 15 errata-xmlrpc 2013-02-21 03:45:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0338.html

Note You need to log in before you can comment on or make changes to this bug.