This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 864962 - mirroring starts anyway with "existing" mode and a non-existing target
mirroring starts anyway with "existing" mode and a non-existing target
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
: ZStream
: 861905 (view as bug list)
Depends On: 814102
Blocks: 844627
  Show dependency treegraph
 
Reported: 2012-10-10 09:47 EDT by RHEL Product and Program Management
Modified: 2013-01-09 20:10 EST (History)
16 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.295.el6_3.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 05:26:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2012-10-10 09:47:09 EDT
This bug has been copied from bug #814102 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 4 Jiri Pallich 2012-10-10 09:48:34 EDT
*** Bug 861905 has been marked as a duplicate of this bug. ***
Comment 7 Paolo Bonzini 2012-10-10 13:02:52 EDT
Note that the patch was already acked for 6.3.z when it was first posted.
Comment 10 juzhang 2012-10-19 04:58:40 EDT
Reproduced on qemu-kvm-0.12.1.2-2.295.el6_3.2.

Steps:
1. { "execute" : "__com.redhat_drive-mirror", "arguments" : { "device" : "drive-virtio-disk0", "target" : "/root/sn1", "format": "qcow2", "mode": "existing", "full" : false } }
{"error": {"class": "OpenFileFailed", "desc": "Could not open '/root/sn1'", "data": {"filename": "/root/sn1"}}}
2. in hmp
(qemu) info block-jobs 
Type mirror, device drive-virtio-disk0: Completed 0 of 0 bytes, speed limit 0 bytes/s

3.{ "execute": "transaction", "arguments": {'actions': [ { 'type': 'blockdev-snapshot-sync', 'data' : { 'device': 'drive-virtio-disk0', 'snapshot-file': '/root/sn1' } }] } }
{"error": {"class": "DeviceInUse", "desc": "Device 'drive-virtio-disk0' is in use", "data": {"device": "drive-virtio-disk0"}}}


Results:
1.(qemu) info block-jobs 
Type mirror, device drive-virtio-disk0: Completed 0 of 0 bytes, speed limit 0 bytes/s
2.{"error": {"class": "DeviceInUse", "desc": "Device 'drive-virtio-disk0' is in use", "data": {"device": "drive-virtio-disk0"}}}


Verify on qemu-kvm-rhev-0.12.1.2-2.295.el6_3.4.x86_64.

Steps:
1.  { "execute" : "__com.redhat_drive-mirror", "arguments" : { "device" : "drive-virtio-disk0", "target" : "/root/sn1", "format": "qcow2", "mode": "existing", "full" : false } }
{"error": {"class": "OpenFileFailed", "desc": "Could not open '/root/sn1'", "data": {"filename": "/root/sn1"}}}
2. { "execute": "transaction", "arguments": {'actions': [ { 'type': 'blockdev-snapshot-sync', 'data' : { 'device': 'drive-virtio-disk0', 'snapshot-file': '/root/sn1' } }] } }
{"return": {}}

Results:
after step1
(qemu) info block-jobs 
No active jobs
after step2
(qemu) info block
drive-virtio-disk0: removable=0 io-status=ok file=/root/sn1 backing_file=/root/blockcopy/rhel6.4.qcow ro=0 drv=qcow2 encrypted=0
Comment 13 errata-xmlrpc 2012-11-01 05:26:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1420.html

Note You need to log in before you can comment on or make changes to this bug.