Bug 864964 - add keyboard accelerators to entries/checkboxes/etc.
add keyboard accelerators to entries/checkboxes/etc.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 887426 (view as bug list)
Depends On:
Blocks: 782468
  Show dependency treegraph
 
Reported: 2012-10-10 09:53 EDT by Martin Banas
Modified: 2013-09-19 09:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-19.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-10 10:33:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Banas 2012-10-10 09:53:57 EDT
Description of problem:
Current newUI anaconda is not usable when there's not mouse available. Installation without mouse (or with unusable touchpad in KVM) is valid usecase for a lot of our customers.

Version-Release number of selected component (if applicable):
anaconda-18.14-1

How reproducible:
always

Steps to Reproduce:
1. Run installation without mouse
  
Actual results:
1. A lot of useful information is displayed in tooltips, which are not visible without mouse.
2. A lot of accelerators are missing, but I suppose this is because of early stage of development.
Comment 1 Chris Lumens 2012-10-10 11:15:45 EDT
I do mouseless installs all the time, so "not usable" is a real stretch.

(1) We try to not use tooltips too much.  Perhaps there's something we can do to make them display with a widget is highlighted, though.

(2) Which accelerators specifically?
Comment 2 Jan Stodola 2012-11-05 10:26:37 EST
For example following accelerators are missing:

Installation summary
* Date & Time
* Language
* Keyboard
* ...

Installation Destination
* Encrypt my data...

Installation Options
* Partition scheme configuration

Manual Partitioning
* add new mount point
* remove mount point
* "Click here to to create them automatically." button
* Mount Point
* Label
* Desired Capacity
* Device Type
* File System
* X storage devices selected

..and so on

Although it is possible to use <Tab> key or arrows to go through all? elements, it is not very comfortable to hit <Tab> key six times and search which element has focus.
Comment 3 Chris Lumens 2012-11-05 11:46:02 EST
The installation summary ones are going to have to remain accessible only via tab.  For the rest, I don't believe we can do anything about them right now without introducing string changes, so it'll have to wait until F19.
Comment 4 Chris Lumens 2012-12-16 09:43:41 EST
*** Bug 887426 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2013-01-04 09:41:18 EST
Actually, I think I can do the spoke selectors too.  I'll be sending out a patch for rawhide shortly.
Comment 6 Chris Lumens 2013-01-07 09:12:26 EST
I've gone through and added an awful lot of keyboard accelerators.  If you find some that are still missing, please just open a new bug and I'll take care of them.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.