Bug 864982 - Alpha transparency doesn't work well with spice-server 0.12 in some circumstances
Alpha transparency doesn't work well with spice-server 0.12 in some circumsta...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: beta
: ---
Assigned To: Yonit Halperin
Desktop QE
: Regression
Depends On:
Blocks: 895654
  Show dependency treegraph
 
Reported: 2012-10-10 10:47 EDT by David Jaša
Modified: 2013-07-03 08:07 EDT (History)
11 users (show)

See Also:
Fixed In Version: spice-server-0.12.0-10
Doc Type: Bug Fix
Doc Text:
Cause: In some circumstances (non-RGB images with no pallete and with masks), images were not used. Consequence: Some images were mis-rendered, such as icons with a black background or white rounded corners Fix: Render such images instead of dropping them Result: Rendering looks better.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:03:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedora white rounded corners (1017.37 KB, image/png)
2012-10-10 10:47 EDT, David Jaša
no flags Details
winxp icon background (483.71 KB, image/png)
2012-10-10 10:49 EDT, David Jaša
no flags Details
winxp icon background (481.95 KB, image/png)
2012-10-10 10:51 EDT, David Jaša
no flags Details
fix for the windows guest issue (7.50 KB, patch)
2012-12-12 08:29 EST, Yonit Halperin
no flags Details | Diff

  None (edit)
Description David Jaša 2012-10-10 10:47:53 EDT
Created attachment 624941 [details]
fedora white rounded corners

Description of problem:
Alpha transparency doesn't work well with spice-server 0.12 in some circumstances

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.320.el6.x86_64
spice-server-0.12.0-1.el6.x86_64
in the VM, current driver has to be used, too (qxl-win 0.1-15, xorg-x11-drv-qxl >= 0.1.0)
client version doesn't matter (you can see the same when using spicec, too)

How reproducible:
100 %

Steps to Reproduce:
1. in windows xp guest, open compmgmt.msc console
2. in fedora 18 guest, open Display properties
3.
  
Actual results:
1. toolbar icons in the console have black background
2. rounded corners of display label are rended white (see the screenshot)

Expected results:
everything is rendered normally 

Additional info:
Comment 1 David Jaša 2012-10-10 10:49:08 EDT
Created attachment 624942 [details]
winxp icon background

note also the white background of "ca.crt" desktop icon
Comment 2 David Jaša 2012-10-10 10:51:36 EDT
Created attachment 624943 [details]
winxp icon background

note that when selected, the tranparency of "ca.crt" icon works just fine

I forgot to write to the description this: the issue is not present in spice-server 0.10
Comment 3 David Jaša 2012-12-12 04:50:55 EST
The bug only shows up for "-M rhel6.3.0" or lower, when using "-M rhel6.4.0", it isn't there. Could this suggest bug in qxl device? BTW bug 886125 reproducibility also depends on qemu machine type.

Host software versions:
spice-server-0.12.0-8.el6.x86_64
qemu-kvm-0.12.1.2-2.340.el6.x86_64
seabios-0.6.1.2-25.el6.x86_64
vgabios-0.6b-3.7.el6.noarch
Comment 4 David Jaša 2012-12-12 04:51:58 EST
in F18, the bug is gone now.
Comment 5 Gerd Hoffmann 2012-12-12 05:03:55 EST
(In reply to comment #3)
> The bug only shows up for "-M rhel6.3.0" or lower, when using "-M
> rhel6.4.0", it isn't there. Could this suggest bug in qxl device? BTW bug
> 886125 reproducibility also depends on qemu machine type.

Could also be a guest driver bug.  rhel 6.4 adds new spice capabilities which indeed affect transparency rendering.  Those are turned off for compatibility reasons when running with the 6.3 machine type.  So it could be the new guest drivers have trouble handling the old qxl device correctly.

The fact that with F18 the bug disappeared (did you update the guest driver?) suggests that it actually is a guest bug.

Do the guests with the new qxl driver show idendical behavior RHEL-6.3 and on RHEL-6.4 when starting qemu with -M rhel6.3.0 ?
Comment 6 Yonit Halperin 2012-12-12 08:29:41 EST
Created attachment 662350 [details]
fix for the windows guest issue

I think that the Linux guest issue results from a different bug than the Windows guest one.
A patch for fixing the Windows guest related bug has been posted (attached).
David, can you open an additional bug for distinguishing the 2 cases?
Comment 7 David Jaša 2012-12-12 08:48:15 EST
(In reply to comment #5)
...
> Could also be a guest driver bug.  rhel 6.4 adds new spice capabilities
> which indeed affect transparency rendering.  Those are turned off for
> compatibility reasons when running with the 6.3 machine type.  So it could
> be the new guest drivers have trouble handling the old qxl device correctly.
> 
> The fact that with F18 the bug disappeared (did you update the guest
> driver?) suggests that it actually is a guest bug.
> 

I didn't update the guest driver (there was no update since 0.1 after all) but there were quite some builds of qemu and spice-server in last two months.

> Do the guests with the new qxl driver show idendical behavior RHEL-6.3 and
> on RHEL-6.4 when starting qemu with -M rhel6.3.0 ?

I couldn't try that because when I'm working with more VM's, I'm experiencing total host freeze... :(


(In reply to comment #6)
...
> David, can you open an additional bug for distinguishing the 2 cases?

I will if I see the bug in Fedora again.
Comment 12 errata-xmlrpc 2013-02-21 05:03:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0529.html

Note You need to log in before you can comment on or make changes to this bug.